Read the docs

privacyIDEA version 2.23.1 and earlier contains a Improper Input Validation vulnerability…

Priority LOW 36CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

privacyIDEA version 2.23.1 and earlier contains a Improper Input Validation vulnerability in token validation api that can result in Denial-of-Service. This attack appear to be exploitable via http request with user=<space>&pass= to /validate/check url. This vulnerability appears to have been fixed in 2.23.2.

Why it matters now

EPSS 0.01689 77th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed privacyIDEA (PyPI): 2.23.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—privacyIDEA (PyPI)before 2.23.22.23.2Patch availableGHSA-7qqv-r2q4-jxhm
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • privacyIDEA (PyPI) Vendor— Affected before 2.23.2 Fixed in 2.23.2 Patch available GHSA-7qqv-r2q4-jxhm

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:privacyidea:privacyidea:*:*:*:*:*:*:*:*up to 2.23.1VulnerablePrivacyidea
  • cpe:2.3:a:privacyidea:privacyidea:*:*:*:*:*:*:*:* Versions up to 2.23.1 Vulnerable ·Privacyidea

Remediation

  • Fix · GHSA-7qqv-r2q4-jxhm privacyIDEA (PyPI) Fixed in 2.23.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000809
  2. 2026-10-03 Alias added: GHSA-7qqv-r2q4-jxhm

References

Sources