The Rust Programming Language Standard Library version 1.29.0, 1.28.0, 1.27.2, 1.27.1…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-190 and the CVSS impact.
Summary
The Rust Programming Language Standard Library version 1.29.0, 1.28.0, 1.27.2, 1.27.1, 127.0, 126.2, 126.1, 126.0 contains a CWE-680: Integer Overflow to Buffer Overflow vulnerability in standard library that can result in buffer overflow. This attack appear to be exploitable via str::repeat, passed a large number, can overflow an internal buffer. This vulnerability appears to have been fixed in 1.29.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rust-lang:rust:1.26.0:*:*:*:*:*:*:* | 1.26.0 | Vulnerable | rust-lang |
| cpe:2.3:a:rust-lang:rust:1.26.1:*:*:*:*:*:*:* | 1.26.1 | Vulnerable | rust-lang |
| cpe:2.3:a:rust-lang:rust:1.26.2:*:*:*:*:*:*:* | 1.26.2 | Vulnerable | rust-lang |
| cpe:2.3:a:rust-lang:rust:1.27.0:*:*:*:*:*:*:* | 1.27.0 | Vulnerable | rust-lang |
| cpe:2.3:a:rust-lang:rust:1.27.1:*:*:*:*:*:*:* | 1.27.1 | Vulnerable | rust-lang |
| cpe:2.3:a:rust-lang:rust:1.27.2:*:*:*:*:*:*:* | 1.27.2 | Vulnerable | rust-lang |
| cpe:2.3:a:rust-lang:rust:1.28.0:*:*:*:*:*:*:* | 1.28.0 | Vulnerable | rust-lang |
| cpe:2.3:a:rust-lang:rust:1.29.0:*:*:*:*:*:*:* | 1.29.0 | Vulnerable | rust-lang |
- cpe:2.3:a:rust-lang:rust:1.26.0:*:*:*:*:*:*:* Versions 1.26.0 Vulnerable ·rust-lang
- cpe:2.3:a:rust-lang:rust:1.26.1:*:*:*:*:*:*:* Versions 1.26.1 Vulnerable ·rust-lang
- cpe:2.3:a:rust-lang:rust:1.26.2:*:*:*:*:*:*:* Versions 1.26.2 Vulnerable ·rust-lang
- cpe:2.3:a:rust-lang:rust:1.27.0:*:*:*:*:*:*:* Versions 1.27.0 Vulnerable ·rust-lang
- cpe:2.3:a:rust-lang:rust:1.27.1:*:*:*:*:*:*:* Versions 1.27.1 Vulnerable ·rust-lang
- cpe:2.3:a:rust-lang:rust:1.27.2:*:*:*:*:*:*:* Versions 1.27.2 Vulnerable ·rust-lang
- cpe:2.3:a:rust-lang:rust:1.28.0:*:*:*:*:*:*:* Versions 1.28.0 Vulnerable ·rust-lang
- cpe:2.3:a:rust-lang:rust:1.29.0:*:*:*:*:*:*:* Versions 1.29.0 Vulnerable ·rust-lang
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000810
- 2026-10-03 Alias added: GHSA-2cg9-g249-7mf2
References
More rust-lang Rust vulnerabilities
- TI-2024-16197 Rusts's `std::process::Command` did not properly escape arguments of batch files on Windows CVSS 3.1CRITICAL 10.0
- TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
- TI-2022-06036 Race condition in std::fs::remove_dir_all in rustlang CVSS 3.1HIGH 7.3
- TI-2021-11383 In the standard library in Rust before 1.52.0, a double free can occur in the… CVSS 3.1CRITICAL 9.8
- TI-2021-09849 In the standard library in Rust before 1.52.0, the Zip implementation can report an… CVSS 3.1CRITICAL 9.8
- TI-2020-18601 In the standard library in Rust before 1.49.0, VecDeque::make_contiguous has a bug that… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2018-1000810 · CVE Program
- CVE-2018-1000810 · NVD
- FIRST EPSS
- GHSA-2cg9-g249-7mf2 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000810 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences