Brave Software Inc.
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
Brave Software Inc. Brave version version 0.22.810 to 0.24.0 contains a Other/Unknown vulnerability in function ContentSettingsObserver::AllowScript() in content_settings_observer.cc that can result in Websites can run inline JavaScript even if script is blocked, making attackers easier to track users. This attack appear to be exploitable via the victim must visit a specially crafted website. This vulnerability appears to have been fixed in 0.25.2.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000815
- 2026-10-03 Alias added: GHSA-56pr-74v5-7m5w
References
More Brave vulnerabilities
- TI-2022-23748 Brave Browser before 1.43.88 allowed a remote attacker to cause a denial of service in… CVSS 3.1MEDIUM 6.5
- TI-2022-23747 Brave Browser before 1.42.51 allowed a remote attacker to cause a denial of service via a… CVSS 3.1MEDIUM 6.5
- TI-2017-05997 Brave 0.12.4 has a Status Bar Obfuscation issue in which a redirection target is shown in… CVSS 3.1MEDIUM 5.3
- TI-2021-20894 In Brave Desktop 1.17 through 1.33 before 1.33.106, when CNAME-based adblocking and a… CVSS 3.1HIGH 7.5
- TI-2021-05777 Information disclosure in https://github.com/brave/brave-core CVSS 3.1MEDIUM 5.9
- TI-2022-23746 Brave Browser before 1.43.34 allowed a remote attacker to cause a denial of service via a… CVSS 3.1MEDIUM 6.5
Sources
- CVE-2018-1000815 · CVE Program
- CVE-2018-1000815 · NVD
- FIRST EPSS
- GHSA-56pr-74v5-7m5w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences