Asset Pipeline Grails Plugin Asset-pipeline plugin version Prior to 2.14.1.1, 2.15.1 and…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Asset Pipeline Grails Plugin Asset-pipeline plugin version Prior to 2.14.1.1, 2.15.1 and 3.0.6 contains a Incorrect Access Control vulnerability in Applications deployed in Jetty that can result in Download .class files and any arbitrary file. This attack appear to be exploitable via Specially crafted GET request containing directory traversal from assets-pipeline context. This vulnerability appears to have been fixed in 2.14.1.1 (for Grails 2.x), 2.15.1 (for Grails 3 and Java 7) and 3.0.6 (for Grails 3 and Java 8).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.grails.plugins:asset-pipeline (Maven) | before 2.14.1 | 2.14.1 | Patch available | GHSA-w73q-mc9g-j56x |
| — | org.grails.plugins:asset-pipeline (Maven) | 2.15.0 to before 2.15.1 | 2.15.1 | Patch available | GHSA-w73q-mc9g-j56x |
| — | org.grails.plugins:asset-pipeline (Maven) | 3.0.0 to before 3.0.6 | 3.0.6 | Patch available | GHSA-w73q-mc9g-j56x |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.grails.plugins:asset-pipeline (Maven) Vendor— Affected before 2.14.1 Fixed in 2.14.1 Patch available GHSA-w73q-mc9g-j56x
- org.grails.plugins:asset-pipeline (Maven) Vendor— Affected 2.15.0 to before 2.15.1 Fixed in 2.15.1 Patch available GHSA-w73q-mc9g-j56x
- org.grails.plugins:asset-pipeline (Maven) Vendor— Affected 3.0.0 to before 3.0.6 Fixed in 3.0.6 Patch available GHSA-w73q-mc9g-j56x
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:asset_pipeline_project:asset-pipeline:*:*:*:*:*:grails:*:* | before 2.14.1.1; after 2.14.1.1, before 2.15.1; after 2.15.1, before 3.0.6 | Vulnerable | Asset Pipeline Project |
- cpe:2.3:a:asset_pipeline_project:asset-pipeline:*:*:*:*:*:grails:*:* Versions before 2.14.1.1; after 2.14.1.1, before 2.15.1; after 2.15.1, before 3.0.6 Vulnerable ·Asset Pipeline Project
Remediation
- Fix · GHSA-w73q-mc9g-j56x org.grails.plugins:asset-pipeline (Maven) Fixed in 2.14.1 Advisory →
- Fix · GHSA-w73q-mc9g-j56x org.grails.plugins:asset-pipeline (Maven) Fixed in 2.15.1 Advisory →
- Fix · GHSA-w73q-mc9g-j56x org.grails.plugins:asset-pipeline (Maven) Fixed in 3.0.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000817
- 2026-10-03 Alias added: GHSA-w73q-mc9g-j56x
References
More Asset Pipeline Project Asset-pipeline vulnerabilities
- TI-2018-12538 An issue was discovered in the Asset Pipeline plugin before 3.0.4 for Grails. CVSS 3.0HIGH 7.5
Sources
- CVE-2018-1000817 · CVE Program
- CVE-2018-1000817 · NVD
- FIRST EPSS
- GHSA-w73q-mc9g-j56x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences