exist version <= 5.0.0-RC4 contains a XML External Entity (XXE) vulnerability in XML…
Priority MEDIUM 47CWE-611Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
exist version <= 5.0.0-RC4 contains a XML External Entity (XXE) vulnerability in XML Parser for REST Server that can result in Disclosure of confidential data, denial of service, SSRF, port scanning.
Why it matters now
EPSS 0.01879 79th percentileScored 2026-11-07
Fix Fixed org.exist-db:exist-core (Maven): 5.1.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.exist-db:exist-core (Maven) | before 5.1.0 | 5.1.0 | Patch available | GHSA-jxm5-5xcw-h57q |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.exist-db:exist-core (Maven) Vendor— Affected before 5.1.0 Fixed in 5.1.0 Patch available GHSA-jxm5-5xcw-h57q
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:exist-db:exist:*:*:*:*:*:*:*:* | before 5.0.0 | Vulnerable | Exist-db |
| cpe:2.3:a:exist-db:exist:5.0.0:rc1:*:*:*:*:*:* | 5.0.0 rc1 | Vulnerable | Exist-db |
| cpe:2.3:a:exist-db:exist:5.0.0:rc2:*:*:*:*:*:* | 5.0.0 rc2 | Vulnerable | Exist-db |
| cpe:2.3:a:exist-db:exist:5.0.0:rc3:*:*:*:*:*:* | 5.0.0 rc3 | Vulnerable | Exist-db |
| cpe:2.3:a:exist-db:exist:5.0.0:rc4:*:*:*:*:*:* | 5.0.0 rc4 | Vulnerable | Exist-db |
- cpe:2.3:a:exist-db:exist:*:*:*:*:*:*:*:* Versions before 5.0.0 Vulnerable ·Exist-db
- cpe:2.3:a:exist-db:exist:5.0.0:rc1:*:*:*:*:*:* Versions 5.0.0 rc1 Vulnerable ·Exist-db
- cpe:2.3:a:exist-db:exist:5.0.0:rc2:*:*:*:*:*:* Versions 5.0.0 rc2 Vulnerable ·Exist-db
- cpe:2.3:a:exist-db:exist:5.0.0:rc3:*:*:*:*:*:* Versions 5.0.0 rc3 Vulnerable ·Exist-db
- cpe:2.3:a:exist-db:exist:5.0.0:rc4:*:*:*:*:*:* Versions 5.0.0 rc4 Vulnerable ·Exist-db
Remediation
- Fix · GHSA-jxm5-5xcw-h57q org.exist-db:exist-core (Maven) Fixed in 5.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000823
- 2026-10-03 Alias added: GHSA-jxm5-5xcw-h57q
References
Advisory 4
Other 6
- https://github.com/eXist-db/exist/pull/2243
- https://github.com/eXist-db/exist/pull/2247
- https://github.com/eXist-db/exist/commit/1c3f0aec14d00bdbca175713af70cb7c7b868e9f
- https://github.com/eXist-db/exist/commit/b210f9fbf379b68842f2b055dda80d7e7479e96f
- https://0dd.zone/2018/10/27/exist-XXE
- https://github.com/eXist-db/exist
Sources
- CVE-2018-1000823 · CVE Program
- CVE-2018-1000823 · NVD
- FIRST EPSS
- GHSA-jxm5-5xcw-h57q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences