Wampserver version prior to version 3.1.5 contains a Cross Site Scripting (XSS)…
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Wampserver version prior to version 3.1.5 contains a Cross Site Scripting (XSS) vulnerability in index.php localhost page that can result in very low. This attack appear to be exploitable via payload onmouseover. This vulnerability appears to have been fixed in 3.1.5 and later.
Why it matters now
EPSS 0.00647 51st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wampserver:wampserver:*:*:*:*:*:*:*:* | before 3.1.5 | Vulnerable | Wampserver |
- cpe:2.3:a:wampserver:wampserver:*:*:*:*:*:*:*:* Versions before 3.1.5 Vulnerable ·Wampserver
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000848
- 2026-10-03 Alias added: GHSA-ggqf-g43q-xrhm
- 2026-10-19 EPSS moved to the 50th–90th percentile
References
More Wampserver vulnerabilities
- TI-2018-06362 Wampserver before 3.1.3 has CSRF in add_vhost.php. CVSS 3.0HIGH 8.8
- TI-2022-16878 Incorrect access control in the install directory (C:\Wamp64) of Wamp v3.2.6 and below… CVSS 3.1HIGH 8.8
- TI-2016-08117 WampServer 3.0.6 installs two services called 'wampapache' and 'wampmysqld' with weak… CVSS 3.0HIGH 7.5
- TI-2019-08607 WampServer before 3.1.9 has CSRF in add_vhost.php because the synchronizer pattern… CVSS 3.0MEDIUM 6.5
- TI-2018-06303 Cross-site scripting (XSS) vulnerability in WampServer 3.1.1 allows remote attackers to… CVSS 3.0MEDIUM 5.4
- TI-2016-08156 WampServer 3.0.6 has two files called 'wampmanager.exe' and 'unins000.exe' with a weak… CVSS 3.1MEDIUM 5.3
Sources
- CVE-2018-1000848 · CVE Program
- CVE-2018-1000848 · NVD
- FIRST EPSS
- GHSA-ggqf-g43q-xrhm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences