Alpine Linux version Versions prior to 2.6.10, 2.7.6, and 2.10.1 contains a Other/Unknown…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
Alpine Linux version Versions prior to 2.6.10, 2.7.6, and 2.10.1 contains a Other/Unknown vulnerability in apk-tools (Alpine Linux' package manager) that can result in Remote Code Execution. This attack appear to be exploitable via A specially crafted APK-file can cause apk to write arbitrary data to an attacker-specified file, due to bugs in handling long link target name and the way a regular file is extracted.. This vulnerability appears to have been fixed in 2.6.10, 2.7.6, and 2.10.1.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:alpinelinux:alpine_linux:*:*:*:*:*:*:*:* | before 2.6.10; 2.7.0 to before 2.7.6; 2.7.7 to before 2.10.1 | Vulnerable | Alpinelinux |
- cpe:2.3:o:alpinelinux:alpine_linux:*:*:*:*:*:*:*:* Versions before 2.6.10; 2.7.0 to before 2.7.6; 2.7.7 to before 2.10.1 Vulnerable ·Alpinelinux
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000849
- 2026-10-03 Alias added: GHSA-fv7m-mhm7-76v2
References
More Alpinelinux Alpine Linux vulnerabilities
- TI-2017-07065 A heap overflow in apk (Alpine Linux's package manager) allows a remote attacker to cause… CVSS 3.0HIGH 7.8
- TI-2017-07063 A heap overflow in apk (Alpine Linux's package manager) allows a remote attacker to cause… CVSS 3.0HIGH 7.8
Sources
- CVE-2018-1000849 · CVE Program
- CVE-2018-1000849 · NVD
- FIRST EPSS
- GHSA-fv7m-mhm7-76v2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences