Read the docs

easymon version 1.4 and earlier contains a Cross Site Scripting (XSS) vulnerability in…

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

easymon version 1.4 and earlier contains a Cross Site Scripting (XSS) vulnerability in Endpoint where monitoring is mounted that can result in Reflected XSS that affects Firefox. Can be used to steal cookies, depending on the cookie settings.. This attack appear to be exploitable via The victim must click on a crafted URL that contains the XSS payload. This vulnerability appears to have been fixed in 1.4.1 and later.

Why it matters now

EPSS 0.00896 59th percentileScored 2026-11-07
Fix Fixed easymon (RubyGems): 1.4.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—easymon (RubyGems)before 1.4.11.4.1Patch availableGHSA-c289-47qf-rvrr
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • easymon (RubyGems) Vendor— Affected before 1.4.1 Fixed in 1.4.1 Patch available GHSA-c289-47qf-rvrr

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:basecamp:easymon:*:*:*:*:*:ruby:*:*up to 1.4Vulnerablebasecamp
  • cpe:2.3:a:basecamp:easymon:*:*:*:*:*:ruby:*:* Versions up to 1.4 Vulnerable ·basecamp

Remediation

  • Fix · GHSA-c289-47qf-rvrr easymon (RubyGems) Fixed in 1.4.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000855
  2. 2026-10-03 Alias added: GHSA-c289-47qf-rvrr

References

Sources