A data modification vulnerability exists in Jenkins 2.153 and earlier, LTS 2.138.3 and…
Priority MEDIUM 45CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- Partial Red Hat: 1 fixed, 8 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
A data modification vulnerability exists in Jenkins 2.153 and earlier, LTS 2.138.3 and earlier in User.java, IdStrategy.java that allows attackers to submit crafted user names that can cause an improper migration of user record storage formats, potentially preventing the victim from logging into Jenkins.
Why it matters now
EPSS 0.06762 94th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.138.4, 2.154Red Hat: 1 fixed, 8 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.138.4 | 2.138.4 | Patch available | GHSA-4jhm-5f7g-75fp |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.140 to before 2.154 | 2.154 | Patch available | GHSA-4jhm-5f7g-75fp |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.138.4 Fixed in 2.138.4 Patch available GHSA-4jhm-5f7g-75fp
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.140 to before 2.154 Fixed in 2.154 Patch available GHSA-4jhm-5f7g-75fp
Remediation
- Fix · GHSA-4jhm-5f7g-75fp org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.138.4 Advisory →
- Fix · GHSA-4jhm-5f7g-75fp org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.154 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.10 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.2 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.3 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.4 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.5 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.6 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.7 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.9 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.11 | Fixed | — |
Not affected: 1 product
- Red Hat OpenShift Container Platform 3.11
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000863
- 2026-10-03 Alias added: GHSA-4jhm-5f7g-75fp
References
Advisory 3
Sources
- CVE-2018-1000863 · CVE Program
- CVE-2018-1000863 · NVD
- FIRST EPSS
- GHSA-4jhm-5f7g-75fp · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000863 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences