A denial of service vulnerability exists in Jenkins 2.153 and earlier, LTS 2.138.3 and…
Priority LOW 34CWE-835Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 fixed, 8 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-835.
Summary
A denial of service vulnerability exists in Jenkins 2.153 and earlier, LTS 2.138.3 and earlier in CronTab.java that allows attackers with Overall/Read permission to have a request handling thread enter an infinite loop.
Why it matters now
EPSS 0.02751 86th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.138.4, 2.154Red Hat: 1 fixed, 8 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.138.4 | 2.138.4 | Patch available | GHSA-9cjv-93g7-c6mv |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.140 to before 2.154 | 2.154 | Patch available | GHSA-9cjv-93g7-c6mv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.138.4 Fixed in 2.138.4 Patch available GHSA-9cjv-93g7-c6mv
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.140 to before 2.154 Fixed in 2.154 Patch available GHSA-9cjv-93g7-c6mv
Remediation
- Fix · GHSA-9cjv-93g7-c6mv org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.138.4 Advisory →
- Fix · GHSA-9cjv-93g7-c6mv org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.154 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.10 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.2 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.3 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.4 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.5 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.6 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.7 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.9 | Affected | No fix planned: Will not fix |
| Red Hat OpenShift Container Platform 3.11 | Fixed | — |
Not affected: 1 product
- Red Hat OpenShift Container Platform 3.11
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000864
- 2026-10-03 Alias added: GHSA-9cjv-93g7-c6mv
References
Sources
- CVE-2018-1000864 · CVE Program
- CVE-2018-1000864 · NVD
- FIRST EPSS
- GHSA-9cjv-93g7-c6mv · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000864 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences