A sandbox bypass vulnerability exists in Script Security Plugin 1.47 and earlier in…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 fixed, 10 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-269.
Summary
A sandbox bypass vulnerability exists in Script Security Plugin 1.47 and earlier in groovy-sandbox/src/main/java/org/kohsuke/groovy/sandbox/SandboxTransformer.java that allows attackers with Job/Configure permission to execute arbitrary code on the Jenkins master JVM, if plugins using the Groovy sandbox are installed.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:script-security (Maven) | before 1.48 | 1.48 | Patch available | GHSA-p4p5-3v2j-w5rv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:script-security (Maven) Vendor— Affected before 1.48 Fixed in 1.48 Patch available GHSA-p4p5-3v2j-w5rv
Remediation
- Fix · GHSA-p4p5-3v2j-w5rv org.jenkins-ci.plugins:script-security (Maven) Fixed in 1.48 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.10 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 3.2 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 3.3 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 3.4 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 3.5 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 3.6 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 3.7 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 3.9 | Affected | No fix yet |
| Red Hat OpenShift Enterprise 3.1 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 3.11 | Fixed | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000865
- 2026-10-03 Alias added: GHSA-p4p5-3v2j-w5rv
References
Sources
- CVE-2018-1000865 · CVE Program
- CVE-2018-1000865 · NVD
- FIRST EPSS
- GHSA-p4p5-3v2j-w5rv · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1000865 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences