Read the docs

A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.59 and earlier in…

Priority MEDIUM 41CWE-269Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Privilege escalation
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 1 fixed, 10 without a fix

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-269.

Summary

A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.59 and earlier in groovy-sandbox/src/main/java/org/kohsuke/groovy/sandbox/SandboxTransformer.java, groovy-cps/lib/src/main/java/com/cloudbees/groovy/cps/SandboxCpsTransformer.java that allows attackers with Job/Configure permission, or unauthorized attackers with SCM commit privileges and corresponding pipelines based on Jenkinsfiles set up in Jenkins, to execute arbitrary code on the Jenkins master JVM

Why it matters now

EPSS 0.01639 76th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.plugins.workflow:workflow-cps (Maven): 2.60org.jenkins-ci.plugins:script-security (Maven): 1.48Red Hat: 1 fixed, 10 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.plugins.workflow:workflow-cps (Maven)before 2.602.60Patch availableGHSA-gqhm-4h93-rrhg
—org.jenkins-ci.plugins:script-security (Maven)before 1.481.48Patch availableGHSA-gqhm-4h93-rrhg
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins.workflow:workflow-cps (Maven) Vendor— Affected before 2.60 Fixed in 2.60 Patch available GHSA-gqhm-4h93-rrhg
  • org.jenkins-ci.plugins:script-security (Maven) Vendor— Affected before 1.48 Fixed in 1.48 Patch available GHSA-gqhm-4h93-rrhg

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:pipeline\:_groovy:*:*:*:*:*:jenkins:*:*_groovyVulnerableJenkins
cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:*3.11VulnerableRed Hat
  • cpe:2.3:a:jenkins:pipeline\:_groovy:*:*:*:*:*:jenkins:*:* Versions _groovy Vulnerable ·Jenkins
  • cpe:2.3:a:redhat:openshift_container_platform:3.11:*:*:*:*:*:*:* Versions 3.11 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-gqhm-4h93-rrhg org.jenkins-ci.plugins.workflow:workflow-cps (Maven) Fixed in 2.60 Advisory →
  • Fix · GHSA-gqhm-4h93-rrhg org.jenkins-ci.plugins:script-security (Maven) Fixed in 1.48 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 3.10AffectedNo fix yet
Red Hat OpenShift Container Platform 3.11AffectedNo fix yet
Red Hat OpenShift Container Platform 3.2AffectedNo fix yet
Red Hat OpenShift Container Platform 3.3AffectedNo fix yet
Red Hat OpenShift Container Platform 3.4AffectedNo fix yet
Red Hat OpenShift Container Platform 3.5AffectedNo fix yet
Red Hat OpenShift Container Platform 3.6AffectedNo fix yet
Red Hat OpenShift Container Platform 3.7AffectedNo fix yet
Red Hat OpenShift Container Platform 3.9AffectedNo fix yet
Red Hat OpenShift Enterprise 3.1AffectedNo fix yet
Red Hat OpenShift Container Platform 3.11Fixed—

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000866
  2. 2026-10-03 Alias added: GHSA-gqhm-4h93-rrhg

References

Sources