Improper input validation in Kubernetes k8s.gcr.io/defaultbackend
Priority LOW 26CWE-215Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Versions < 1.5 of the Kubernetes ingress default backend, which handles invalid ingress traffic, exposed prometheus metrics publicly.
Why it matters now
EPSS 0.01138 66th percentileScored 2026-11-07
Fix Fixed k8s.gcr.io/defaultbackend (Kubernetes): 1.5k8s.io/ingress-nginx (Go): 1.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Kubernetes | k8s.gcr.io/defaultbackend | defaultbackend to before 1.5 | 1.5 | Patch available | CNA |
| — | k8s.io/ingress-nginx (Go) | before 1.5 | 1.5 | Patch available | GHSA-p3x5-5xpx-9phm |
- k8s.gcr.io/defaultbackend VendorKubernetes Affected defaultbackend to before 1.5 Fixed in 1.5 Patch available CNA
- k8s.io/ingress-nginx (Go) Vendor— Affected before 1.5 Fixed in 1.5 Patch available GHSA-p3x5-5xpx-9phm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kubernetes:nginx_ingress_controller:*:*:*:*:*:*:*:* | before 1.5.0 | Vulnerable | Kubernetes |
- cpe:2.3:a:kubernetes:nginx_ingress_controller:*:*:*:*:*:*:*:* Versions before 1.5.0 Vulnerable ·Kubernetes
Remediation
- Fix · CNA k8s.gcr.io/defaultbackend (Kubernetes) Fixed in 1.5
- Fix · GHSA-p3x5-5xpx-9phm k8s.io/ingress-nginx (Go) Fixed in 1.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat OpenShift Container Platform 3.11
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1002104
- 2026-10-03 Alias added: GHSA-p3x5-5xpx-9phm
References
More Kubernetes Nginx Ingress Controller vulnerabilities
- TI-2026-03779 ingress-nginx comment-based nginx configuration injection CVSS 3.1HIGH 8.8
Sources
- CVE-2018-1002104 · CVE Program
- CVE-2018-1002104 · NVD
- FIRST EPSS
- GHSA-p3x5-5xpx-9phm · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1002104 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences