A Improper authorization vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and…
Priority LOW 22CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-863.
Summary
A Improper authorization vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in SlaveComputer.java that allows attackers with Overall/Read permission to initiate agent launches, and abort in-progress agent launches.
Why it matters now
EPSS 0.00942 61st percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.121.2, 2.132Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.121.2 | 2.121.2 | Patch available | GHSA-wmr8-25ff-ggpj |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.122 to before 2.132 | 2.132 | Patch available | GHSA-wmr8-25ff-ggpj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.121.2 Fixed in 2.121.2 Patch available GHSA-wmr8-25ff-ggpj
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.122 to before 2.132 Fixed in 2.132 Patch available GHSA-wmr8-25ff-ggpj
Remediation
- Fix · GHSA-wmr8-25ff-ggpj org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.121.2 Advisory →
- Fix · GHSA-wmr8-25ff-ggpj org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.132 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 3 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1999004
- 2026-10-03 Alias added: GHSA-wmr8-25ff-ggpj
References
Advisory 2
Sources
- CVE-2018-1999004 · CVE Program
- CVE-2018-1999004 · NVD
- FIRST EPSS
- GHSA-wmr8-25ff-ggpj · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1999004 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences