Read the docs

A cross-site scripting vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and…

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

A cross-site scripting vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in the Stapler web framework's org/kohsuke/stapler/Stapler.java that allows attackers with the ability to control the existence of some URLs in Jenkins to define JavaScript that would be executed in another user's browser when that other user views HTTP 404 error pages while Stapler debug mode is enabled.

Why it matters now

EPSS 0.00894 59th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.121.2, 2.132org.kohsuke.stapler:stapler-parent (Maven): 1.250.1Red Hat: 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)before 2.121.22.121.2Patch availableGHSA-6456-xjm5-g3pg
—org.jenkins-ci.main:jenkins-core (Maven)2.122 to before 2.1322.132Patch availableGHSA-6456-xjm5-g3pg
—org.kohsuke.stapler:stapler-parent (Maven)before 1.250.11.250.1Patch availableGHSA-6456-xjm5-g3pg
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.121.2 Fixed in 2.121.2 Patch available GHSA-6456-xjm5-g3pg
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.122 to before 2.132 Fixed in 2.132 Patch available GHSA-6456-xjm5-g3pg
  • org.kohsuke.stapler:stapler-parent (Maven) Vendor— Affected before 1.250.1 Fixed in 1.250.1 Patch available GHSA-6456-xjm5-g3pg

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:*up to 2.121.1; 2.122 – 2.132VulnerableJenkins
cpe:2.3:a:oracle:communications_cloud_native_core_automated_test_suite:1.9.0:*:*:*:*:*:*:*1.9.0VulnerableOracle
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* Versions up to 2.121.1; 2.122 – 2.132 Vulnerable ·Jenkins
  • cpe:2.3:a:oracle:communications_cloud_native_core_automated_test_suite:1.9.0:*:*:*:*:*:*:* Versions 1.9.0 Vulnerable ·Oracle

Remediation

  • Fix · GHSA-6456-xjm5-g3pg org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.121.2 Advisory →
  • Fix · GHSA-6456-xjm5-g3pg org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.132 Advisory →
  • Fix · GHSA-6456-xjm5-g3pg org.kohsuke.stapler:stapler-parent (Maven) Fixed in 1.250.1 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Enterprise 3AffectedNo fix yet

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1999007
  2. 2026-10-03 Alias added: GHSA-6456-xjm5-g3pg

References

Sources