PEAR HTML_QuickForm version 3.2.14 contains an eval injection (CWE-95) vulnerability in…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-94.
Summary
PEAR HTML_QuickForm version 3.2.14 contains an eval injection (CWE-95) vulnerability in HTML_QuickForm's getSubmitValue method, HTML_QuickForm's validate method, HTML_QuickForm_hierselect's _setOptions method, HTML_QuickForm_element's _findValue method, HTML_QuickForm_element's _prepareValue method. that can result in Possible information disclosure, possible impact on data integrity and execution of arbitrary code. This attack appear to be exploitable via A specially crafted query string could be utilised, e.g. http://www.example.com/admin/add_practice_type_id[1]=fubar%27])%20OR%20die(%27OOK!%27);%20//&mode=live. This vulnerability appears to have been fixed in 3.2.15.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:html_quickform_project:html_quickform:3.2.14:*:*:*:*:*:*:* | 3.2.14 | Vulnerable | Html Quickform Project |
| cpe:2.3:a:civicrm:civicrm:*:*:*:*:*:*:*:* | up to 4.6.37 | Vulnerable | CiviCRM |
| cpe:2.3:a:civicrm:civicrm:5.3.0:*:*:*:*:*:*:* | 5.3.0 | Vulnerable | CiviCRM |
- cpe:2.3:a:html_quickform_project:html_quickform:3.2.14:*:*:*:*:*:*:* Versions 3.2.14 Vulnerable ·Html Quickform Project
- cpe:2.3:a:civicrm:civicrm:*:*:*:*:*:*:*:* Versions up to 4.6.37 Vulnerable ·CiviCRM
- cpe:2.3:a:civicrm:civicrm:5.3.0:*:*:*:*:*:*:* Versions 5.3.0 Vulnerable ·CiviCRM
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1999022
- 2026-10-03 Alias added: GHSA-ppg7-5cr7-7v24
References
Sources
- CVE-2018-1999022 · CVE Program
- CVE-2018-1999022 · NVD
- FIRST EPSS
- GHSA-ppg7-5cr7-7v24 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1999022 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences