A confused deputy vulnerability exists in Jenkins Publisher Over CIFS Plugin 0.10 and…
Priority LOW 20CWE-441Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
A confused deputy vulnerability exists in Jenkins Publisher Over CIFS Plugin 0.10 and earlier in CifsPublisherPluginDescriptor.java that allows attackers to have Jenkins connect to an attacker specified CIFS server with attacker specified credentials.
Why it matters now
EPSS 0.00483 41st percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:publish-over-cifs (Maven): 0.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:publish-over-cifs (Maven) | before 0.11 | 0.11 | Patch available | GHSA-rf7h-9m85-535v |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:publish-over-cifs (Maven) Vendor— Affected before 0.11 Fixed in 0.11 Patch available GHSA-rf7h-9m85-535v
Remediation
- Fix · GHSA-rf7h-9m85-535v org.jenkins-ci.plugins:publish-over-cifs (Maven) Fixed in 0.11 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1999038
- 2026-10-03 Alias added: GHSA-rf7h-9m85-535v
References
Sources
- CVE-2018-1999038 · CVE Program
- CVE-2018-1999038 · NVD
- FIRST EPSS
- GHSA-rf7h-9m85-535v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences