Read the docs

A server-side request forgery vulnerability exists in Jenkins Confluence Publisher Plugin…

Priority LOW 21CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

A server-side request forgery vulnerability exists in Jenkins Confluence Publisher Plugin 2.0.1 and earlier in ConfluenceSite.java that allows attackers to have Jenkins submit login requests to an attacker-specified Confluence server URL with attacker specified credentials.

Why it matters now

EPSS 0.00642 51st percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:confluence-publisher (Maven): 2.0.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.plugins:confluence-publisher (Maven)before 2.0.22.0.2Patch availableGHSA-5339-9974-hqj9
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:confluence-publisher (Maven) Vendor— Affected before 2.0.2 Fixed in 2.0.2 Patch available GHSA-5339-9974-hqj9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:confluence_publisher:*:*:*:*:*:jenkins:*:*up to 2.0.1VulnerableJenkins
  • cpe:2.3:a:jenkins:confluence_publisher:*:*:*:*:*:jenkins:*:* Versions up to 2.0.1 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-5339-9974-hqj9 org.jenkins-ci.plugins:confluence-publisher (Maven) Fixed in 2.0.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1999039
  2. 2026-10-03 Alias added: GHSA-5339-9974-hqj9
  3. 2026-10-21 EPSS moved to the 50th–90th percentile

References

Sources