Malicious Package in eslint-scope
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Code execution
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-506.
Summary
Version 3.7.2 of `eslint-scope` was published without authorization and was found to contain malicious code. This code would read the users `.npmrc` file and send any found authentication tokens to 2 remote servers. ## Recommendation The best course of action if you found this package installed in your environment is to revoke all your npm tokens. You can find instructions on how to do that here. https://docs.npmjs.com/getting-started/working_with_tokens#how-to-revoke-tokens
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | eslint-scope (npm) | 3.7.2 to before 3.7.3 | 3.7.3 | Patch available | GHSA-hxxf-q3w9-4xgw |
| — | eslint-config-eslint (npm) | 5.0.2 to before 6.0.0 | 6.0.0 | Patch available | GHSA-hxxf-q3w9-4xgw |
- eslint-scope (npm) Vendor— Affected 3.7.2 to before 3.7.3 Fixed in 3.7.3 Patch available GHSA-hxxf-q3w9-4xgw
- eslint-config-eslint (npm) Vendor— Affected 5.0.2 to before 6.0.0 Fixed in 6.0.0 Patch available GHSA-hxxf-q3w9-4xgw
Remediation
- Fix · GHSA-hxxf-q3w9-4xgw eslint-scope (npm) Fixed in 3.7.3 Advisory →
- Fix · GHSA-hxxf-q3w9-4xgw eslint-config-eslint (npm) Fixed in 6.0.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-hxxf-q3w9-4xgw
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences