Read the docs
TI-2018-16190 Aliases GHSA-wm77-q74p-5763

Path Traversal in superstatic

Priority LOW 38CWE-177Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

Affected of `superstatic` are vulnerable to path traversal when used on Windows. Additionally, it is vulnerable to path traversal on other platforms combined with certain Node.js versions which erroneously normalize `\\` to `/` in paths on all platforms (a known example being Node.js v9.9.0). ## Recommendation Update to version 5.0.2 or later.

Why it matters now

Fix Fixed superstatic (npm): 5.0.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—superstatic (npm)before 5.0.25.0.2Patch availableGHSA-wm77-q74p-5763
  • superstatic (npm) Vendor— Affected before 5.0.2 Fixed in 5.0.2 Patch available GHSA-wm77-q74p-5763

Remediation

  • Fix · GHSA-wm77-q74p-5763 superstatic (npm) Fixed in 5.0.2 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-wm77-q74p-5763

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences