Critical severity vulnerability that affects event-stream and flatmap-stream
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Code execution
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-506.
Summary
The NPM package `flatmap-stream` is considered malicious. A malicious actor added this package as a dependency to the NPM `event-stream` package in version `3.3.6`. Users of `event-stream` are encouraged to downgrade to the last non-malicious version, `3.3.4`, or upgrade to the latest 4.x version. Users of `flatmap-stream` are encouraged to remove the dependency entirely.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | event-stream (npm) | 3.3.6 to before 4.0.0 | 4.0.0 | Patch available | GHSA-mh6f-8j2x-4483 |
| — | flatmap-stream (npm) | all versions | — | No fix listed | GHSA-mh6f-8j2x-4483 |
- event-stream (npm) Vendor— Affected 3.3.6 to before 4.0.0 Fixed in 4.0.0 Patch available GHSA-mh6f-8j2x-4483
- flatmap-stream (npm) Vendor— Affected all versions Fixed in — No fix listed GHSA-mh6f-8j2x-4483
Remediation
- Fix · GHSA-mh6f-8j2x-4483 event-stream (npm) Fixed in 4.0.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-mh6f-8j2x-4483
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences