Broken or risky cryptographic algorithm in Apache JMeter
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-327 and CWE-502.
Summary
Unauthenticated RCE is possible when JMeter is used in distributed mode (-r or -R command line options). Attacker can establish a RMI connection to a jmeter-server using RemoteJMeterEngine and proceed with an attack using untrusted data deserialization. This only affect tests running in Distributed mode. Note that versions before 4.0 are not able to encrypt traffic between the nodes, nor authenticate the participating nodes so upgrade to JMeter 5.1 is also advised.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache JMeter | Apache JMeter 4.0 to 5.0 | — | No fix listed | CNA |
| — | org.apache.jmeter:ApacheJMeter (Maven) | before 5.1 | 5.1 | Patch available | GHSA-wg37-7mrv-cfwm |
- Apache JMeter VendorApache Affected Apache JMeter 4.0 to 5.0 Fixed in — No fix listed CNA
- org.apache.jmeter:ApacheJMeter (Maven) Vendor— Affected before 5.1 Fixed in 5.1 Patch available GHSA-wg37-7mrv-cfwm
Remediation
- Fix · GHSA-wg37-7mrv-cfwm org.apache.jmeter:ApacheJMeter (Maven) Fixed in 5.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-0187
- 2026-10-03 Alias added: GHSA-wg37-7mrv-cfwm
References
More Apache Jmeter vulnerabilities
- TI-2021-04451 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.1
- TI-2021-04446 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
- TI-2021-04444 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
- TI-2021-04445 XStream is vulnerable to a Remote Command Execution attack CVSS 3.1CRITICAL 9.9
- TI-2021-04441 XStream can cause a Denial of Service CVSS 3.1HIGH 7.5
- TI-2021-04442 Deserialization of untrusted data in xstream CVSS 3.1CRITICAL 9.1
Sources
- CVE-2019-0187 · CVE Program
- CVE-2019-0187 · NVD
- FIRST EPSS
- GHSA-wg37-7mrv-cfwm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences