An access permission override in Apache Struts 2.0.0 to 2.5.20 may cause a Denial of…
Priority HIGH 69CWE-281Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
An access permission override in Apache Struts 2.0.0 to 2.5.20 may cause a Denial of Service when performing a file upload.
Why it matters now
EPSS 0.66146 99th percentileScored 2026-11-07
Fix Partial org.apache.struts:struts2-core (Maven): 2.5.22Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Apache Struts | Apache Struts 2.0.0 to 2.5.20 | — | No fix listed | CNA |
| — | org.apache.struts:struts2-core (Maven) | 2.0.0 to before 2.5.22 | 2.5.22 | Patch available | GHSA-ccp5-gg58-pxfm |
- Apache Struts Vendor— Affected Apache Struts 2.0.0 to 2.5.20 Fixed in — No fix listed CNA
- org.apache.struts:struts2-core (Maven) Vendor— Affected 2.0.0 to before 2.5.22 Fixed in 2.5.22 Patch available GHSA-ccp5-gg58-pxfm
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:* | 2.0.0 – 2.5.20 | Vulnerable | Apache |
| cpe:2.3:a:oracle:communications_policy_management:12.5.0:*:*:*:*:*:*:* | 12.5.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:financial_services_data_integration_hub:8.0.3:*:*:*:*:*:*:* | 8.0.3 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:financial_services_data_integration_hub:8.0.6:*:*:*:*:*:*:* | 8.0.6 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:financial_services_market_risk_measurement_and_management:8.0.6:*:*:*:*:*:*:* | 8.0.6 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:mysql_enterprise_monitor:*:*:*:*:*:*:*:* | up to 8.0.23 | Vulnerable | Oracle |
- cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:* Versions 2.0.0 – 2.5.20 Vulnerable ·Apache
- cpe:2.3:a:oracle:communications_policy_management:12.5.0:*:*:*:*:*:*:* Versions 12.5.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:financial_services_data_integration_hub:8.0.3:*:*:*:*:*:*:* Versions 8.0.3 Vulnerable ·Oracle
- cpe:2.3:a:oracle:financial_services_data_integration_hub:8.0.6:*:*:*:*:*:*:* Versions 8.0.6 Vulnerable ·Oracle
- cpe:2.3:a:oracle:financial_services_market_risk_measurement_and_management:8.0.6:*:*:*:*:*:*:* Versions 8.0.6 Vulnerable ·Oracle
- cpe:2.3:a:oracle:mysql_enterprise_monitor:*:*:*:*:*:*:*:* Versions up to 8.0.23 Vulnerable ·Oracle
Remediation
- Fix · GHSA-ccp5-gg58-pxfm org.apache.struts:struts2-core (Maven) Fixed in 2.5.22 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Out of support scope |
Not affected: 4 products
- Red Hat JBoss Enterprise Application Platform 6
- Red Hat JBoss Fuse Service Works 6
- Red Hat JBoss Operations Network 3
- Red Hat OpenStack Platform 10 (Newton)
Timeline
- 2026-10-02 Threatist record created from CVE-2019-0233
- 2026-10-03 Alias added: GHSA-ccp5-gg58-pxfm
References
Patch 3
Sources
- CVE-2019-0233 · CVE Program
- CVE-2019-0233 · NVD
- FIRST EPSS
- GHSA-ccp5-gg58-pxfm · GitHub Advisory Database · CC BY 4.0
- CVE-2019-0233 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences