Missing authorization in SAP BASIS
Priority MEDIUM 40CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-862.
Summary
ABAP BASIS function modules INST_CREATE_R3_RFC_DEST, INST_CREATE_TCPIP_RFCDEST, and INST_CREATE_TCPIP_RFC_DEST in SAP BASIS (fixed in versions 7.0 to 7.02, 7.10 to 7.30, 7.31, 7.40, 7.50 to 7.53) do not perform necessary authorization checks in all circumstances for an authenticated user, resulting in escalation of privileges.
Why it matters now
EPSS 0.0111 66th percentileScored 2026-11-07
Fix Fixed SAP BASIS (SAP SE): 7.31, 7.40
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP BASIS | < from 7.00 to 7.02; < from 7.10 to 7.30; before 7.31; before 7.40; < from 7.50 to 7.53 | 7.31, 7.40 | Patch available | CNA |
- SAP BASIS VendorSAP Affected < from 7.00 to 7.02; < from 7.10 to 7.30; before 7.31; before 7.40; < from 7.50 to 7.53 Fixed in 7.31, 7.40 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:business_application_software_integrated_solution:*:*:*:*:*:*:*:* | 7.00 – 7.02; 7.10 – 7.30; 7.50 – 7.53 | Vulnerable | SAP |
| cpe:2.3:a:sap:business_application_software_integrated_solution:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
| cpe:2.3:a:sap:business_application_software_integrated_solution:7.40:*:*:*:*:*:*:* | 7.40 | Vulnerable | SAP |
- cpe:2.3:a:sap:business_application_software_integrated_solution:*:*:*:*:*:*:*:* Versions 7.00 – 7.02; 7.10 – 7.30; 7.50 – 7.53 Vulnerable ·SAP
- cpe:2.3:a:sap:business_application_software_integrated_solution:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
- cpe:2.3:a:sap:business_application_software_integrated_solution:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
Remediation
- Fix · CNA SAP BASIS (SAP SE) Fixed in 7.31, 7.40
Timeline
- 2026-10-02 Threatist record created from CVE-2019-0279
- 2026-10-03 Alias added: GHSA-mvgq-h74j-hhm6
References
More SAP Business Application Software Integrated Solution vulnerabilities
- TI-2018-01755 Path traversal in SAP BASIS CVSS 3.0HIGH 8.8
- TI-2018-01751 Code injection in SAP NetWeaver CVSS 3.0HIGH 8.8
- TI-2018-01871 Incorrect authorization in SAP Basis CVSS 3.0HIGH 8.0
- TI-2017-12272 Code injection in SAP NetWeaver Internet Transaction Server CVSS 3.0HIGH 7.2
- TI-2017-12279 Improper input validation in SAP Note Assistant CVSS 3.0MEDIUM 6.5
Sources
- CVE-2019-0279 · CVE Program
- CVE-2019-0279 · NVD
- FIRST EPSS
- GHSA-mvgq-h74j-hhm6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences