Cross-site scripting in SAP E-Commerce
Priority LOW 32CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
An authenticated attacker in SAP E-Commerce (Business-to-Consumer application), versions 7.3, 7.31, 7.32, 7.33, 7.54, can change the price of the product to zero and also checkout, by injecting an HTML code in the application that will be executed whenever the victim logs in to the application even on a different machine, leading to Code Injection.
Why it matters now
EPSS 0.00842 58th percentileScored 2026-11-07
Fix Fixed SAP E-Commerce (Business-to-Consumer application) (SAP SE): 7.3, 7.31, 7.32 +2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP E-Commerce (Business-to-Consumer application) | before 7.3; before 7.31; before 7.32; before 7.33; before 7.54 | 7.3, 7.31, 7.32, 7.33, 7.54 | Patch available | CNA |
- SAP E-Commerce (Business-to-Consumer application) VendorSAP Affected before 7.3; before 7.31; before 7.32; before 7.33; before 7.54 Fixed in 7.3, 7.31, 7.32, 7.33, 7.54 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:e-commerce:7.30:*:*:*:*:*:*:* | 7.30 | Vulnerable | SAP |
| cpe:2.3:a:sap:e-commerce:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
| cpe:2.3:a:sap:e-commerce:7.32:*:*:*:*:*:*:* | 7.32 | Vulnerable | SAP |
| cpe:2.3:a:sap:e-commerce:7.33:*:*:*:*:*:*:* | 7.33 | Vulnerable | SAP |
| cpe:2.3:a:sap:e-commerce:7.54:*:*:*:*:*:*:* | 7.54 | Vulnerable | SAP |
- cpe:2.3:a:sap:e-commerce:7.30:*:*:*:*:*:*:* Versions 7.30 Vulnerable ·SAP
- cpe:2.3:a:sap:e-commerce:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
- cpe:2.3:a:sap:e-commerce:7.32:*:*:*:*:*:*:* Versions 7.32 Vulnerable ·SAP
- cpe:2.3:a:sap:e-commerce:7.33:*:*:*:*:*:*:* Versions 7.33 Vulnerable ·SAP
- cpe:2.3:a:sap:e-commerce:7.54:*:*:*:*:*:*:* Versions 7.54 Vulnerable ·SAP
Remediation
- Fix · CNA SAP E-Commerce (Business-to-Consumer application) (SAP SE) Fixed in 7.3, 7.31, 7.32, 7.33, 7.54
Timeline
- 2026-10-02 Threatist record created from CVE-2019-0308
- 2026-10-03 Alias added: GHSA-mh58-mm5c-49p8
References
More SAP E-commerce vulnerabilities
- TI-2019-00251 Cross-site scripting in SAP E-Commerce CVSS 3.0MEDIUM 6.1
Sources
- CVE-2019-0308 · CVE Program
- CVE-2019-0308 · NVD
- FIRST EPSS
- GHSA-mh58-mm5c-49p8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences