Under certain conditions SAP NetWeaver Application Server for Java (Startup Framework)…
Priority LOW 27Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
Under certain conditions SAP NetWeaver Application Server for Java (Startup Framework), versions 7.21, 7.22, 7.45, 7.49, and 7.53, allows an attacker to access information which would otherwise be restricted.
Why it matters now
EPSS 0.01335 71st percentileScored 2026-11-07
Fix Fixed SAP NetWeaver Application Server for Java (Startup Framework) (SAP SE): 7.21, 7.22, 7.45 +2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP NetWeaver Application Server for Java (Startup Framework) | before 7.21; before 7.22; before 7.45; before 7.49; before 7.53 | 7.21, 7.22, 7.45, 7.49, 7.53 | Patch available | CNA |
- SAP NetWeaver Application Server for Java (Startup Framework) VendorSAP Affected before 7.21; before 7.22; before 7.45; before 7.49; before 7.53 Fixed in 7.21, 7.22, 7.45, 7.49, 7.53 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver_application_server_java:7.21:*:*:*:*:*:*:* | 7.21 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.22:*:*:*:*:*:*:* | 7.22 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.45:*:*:*:*:*:*:* | 7.45 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.49:*:*:*:*:*:*:* | 7.49 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.53:*:*:*:*:*:*:* | 7.53 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver_application_server_java:7.21:*:*:*:*:*:*:* Versions 7.21 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.22:*:*:*:*:*:*:* Versions 7.22 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.45:*:*:*:*:*:*:* Versions 7.45 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.49:*:*:*:*:*:*:* Versions 7.49 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.53:*:*:*:*:*:*:* Versions 7.53 Vulnerable ·SAP
Remediation
- Fix · CNA SAP NetWeaver Application Server for Java (Startup Framework) (SAP SE) Fixed in 7.21, 7.22, 7.45, 7.49, 7.53
Timeline
- 2026-10-02 Threatist record created from CVE-2019-0318
- 2026-10-03 Alias added: GHSA-747g-w968-634p
References
More SAP Netweaver Application Server Java vulnerabilities
- TI-2020-05139 Missing authentication in SAP NetWeaver AS JAVA KEVCVSS 3.1CRITICAL 10.0
- TI-2016-02146 SQL injection vulnerability in the UDDI server in SAP NetWeaver J2EE Engine 7.40 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2010-05023 The Invoker Servlet on SAP NetWeaver Application Server Java platforms, possibly before… KEVCVSS 3.1CRITICAL 10.0
- TI-2017-09362 Directory traversal vulnerability in scheduler/ui/js/ffffffffbca41eb4/UIUtilJavaScriptJS… KEVCVSS 3.1HIGH 7.5
- TI-2016-03377 Directory traversal vulnerability in SAP NetWeaver AS Java 7.1 through 7.5 allows remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07786 BC-BMT-BPM-DSK in SAP NetWeaver AS JAVA 7.5 allows remote authenticated users to conduct… KEVCVSS 3.1MEDIUM 6.5
Sources
- CVE-2019-0318 · CVE Program
- CVE-2019-0318 · NVD
- FIRST EPSS
- GHSA-747g-w968-634p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences