Cross-site scripting in SAP ABAP Server and ABAP Platform
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
ABAP Server and ABAP Platform (SAP Basis), versions, 7.31, 7.4, 7.5, do not sufficiently encode user-controlled inputs, resulting in Cross-Site Scripting (XSS) vulnerability.
Why it matters now
EPSS 0.01337 71st percentileScored 2026-11-07
Fix Fixed ABAP Server and ABAP Platform (SAP Basis) (SAP SE): 7.31, 7.4, 7.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | ABAP Server and ABAP Platform (SAP Basis) | before 7.31; before 7.4; before 7.5 | 7.31, 7.4, 7.5 | Patch available | CNA |
- ABAP Server and ABAP Platform (SAP Basis) VendorSAP Affected before 7.31; before 7.4; before 7.5 Fixed in 7.31, 7.4, 7.5 Patch available CNA
Remediation
- Fix · CNA ABAP Server and ABAP Platform (SAP Basis) (SAP SE) Fixed in 7.31, 7.4, 7.5
Timeline
- 2026-10-02 Threatist record created from CVE-2019-0321
- 2026-10-03 Alias added: GHSA-v6gj-m3g3-p36w
References
More SAP Netweaver Application Server Abap vulnerabilities
- TI-2022-06811 SAP NetWeaver Application Server ABAP, SAP NetWeaver Application Server Java, ABAP… KEVCVSS 3.1CRITICAL 10.0
- TI-2023-21149 Missing Authorization check in SAP CommonCryptoLib CVSS 3.1CRITICAL 9.8
- TI-2023-12229 Directory Traversal vulnerability in SAP NetWeaver AS for ABAP and ABAP Platform CVSS 3.1CRITICAL 9.6
- TI-2023-12228 Directory Traversal vulnerability in SAP NetWeaver AS for ABAP and ABAP Platform CVSS 3.1CRITICAL 9.6
- TI-2021-19921 Code injection in SAP ABAP Server & ABAP Platform CVSS 3.1CRITICAL 9.8
- TI-2021-09062 Improper authentication in SAP NetWeaver AS ABAP and ABAP Platform CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-0321 · CVE Program
- CVE-2019-0321 · NVD
- FIRST EPSS
- GHSA-v6gj-m3g3-p36w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences