OS command injection in SAP NetWeaver Process Integration ABAP tests
Priority LOW 38CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
ABAP Tests Modules (SAP Basis, versions 7.0, 7.1, 7.3, 7.31, 7.4, 7.5) of SAP NetWeaver Process Integration enables an attacker the execution of OS commands with privileged rights. An attacker could thereby impact the integrity and availability of the system.
Why it matters now
EPSS 0.03359 88th percentileScored 2026-11-07
Fix Fixed SAP NetWeaver Process Integration ABAP tests (SAP Basis) (SAP SE): 7.0, 7.1, 7.3 +3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP NetWeaver Process Integration ABAP tests (SAP Basis) | before 7.0; before 7.1; before 7.3; before 7.31; before 7.4; before 7.5 | 7.0, 7.1, 7.3, 7.31, 7.4, 7.5 | Patch available | CNA |
- SAP NetWeaver Process Integration ABAP tests (SAP Basis) VendorSAP Affected before 7.0; before 7.1; before 7.3; before 7.31; before 7.4; before 7.5 Fixed in 7.0, 7.1, 7.3, 7.31, 7.4, 7.5 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver_process_integration:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_process_integration:7.1:*:*:*:*:*:*:* | 7.1 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_process_integration:7.3:*:*:*:*:*:*:* | 7.3 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_process_integration:7.4:*:*:*:*:*:*:* | 7.4 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_process_integration:7.5:*:*:*:*:*:*:* | 7.5 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_process_integration:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver_process_integration:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_process_integration:7.1:*:*:*:*:*:*:* Versions 7.1 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_process_integration:7.3:*:*:*:*:*:*:* Versions 7.3 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_process_integration:7.4:*:*:*:*:*:*:* Versions 7.4 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_process_integration:7.5:*:*:*:*:*:*:* Versions 7.5 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_process_integration:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
Remediation
- Fix · CNA SAP NetWeaver Process Integration ABAP tests (SAP Basis) (SAP SE) Fixed in 7.0, 7.1, 7.3, 7.31, 7.4, 7.5
Timeline
- 2026-10-02 Threatist record created from CVE-2019-0328
- 2026-10-03 Alias added: GHSA-mf36-xjqx-xw36
References
More SAP Netweaver Process Integration vulnerabilities
- TI-2022-19777 Missing authentication in SAP NetWeaver Process Integration CVSS 3.1CRITICAL 9.9
- TI-2022-19776 Missing authentication in SAP NetWeaver Process Integration CVSS 3.1CRITICAL 9.4
- TI-2023-17944 Missing Authentication check in SAP NetWeaver Process Integration (Runtime Workbench) CVSS 3.1MEDIUM 6.5
- TI-2023-17943 Missing Authentication check in SAP NetWeaver Process Integration (Message Display Tool) CVSS 3.1MEDIUM 6.5
- TI-2019-00262 Under certain conditions the PI Integration Builder Web UI of SAP NetWeaver Process… CVSS 3.0HIGH 7.5
- TI-2019-00244 Authentication bypass by spoofing in SAP NetWeaver Process Integration CVSS 3.0HIGH 7.1
Sources
- CVE-2019-0328 · CVE Program
- CVE-2019-0328 · NVD
- FIRST EPSS
- GHSA-mf36-xjqx-xw36 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences