Authentication bypass by spoofing in SAP UI
Priority LOW 25CWE-290Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-290.
Summary
SAP UI5 HTTP Handler (corrected in SAP_UI versions 7.5, 7.51, 7.52, 7.53, 7.54 and SAP UI_700 version 2.0) allows an attacker to manipulate content due to insufficient URL validation.
Why it matters now
EPSS 0.00727 54th percentileScored 2026-11-07
Fix Fixed SAP UI (SAP SE): 7.5, 7.51, 7.52 +2SAP UI 700 (SAP SE): 2.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP UI | before 7.5; before 7.51; before 7.52; before 7.53; before 7.54 | 7.5, 7.51, 7.52, 7.53, 7.54 | Patch available | CNA |
| SAP | SAP UI 700 | before 2.0 | 2.0 | Patch available | CNA |
- SAP UI VendorSAP Affected before 7.5; before 7.51; before 7.52; before 7.53; before 7.54 Fixed in 7.5, 7.51, 7.52, 7.53, 7.54 Patch available CNA
- SAP UI 700 VendorSAP Affected before 2.0 Fixed in 2.0 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:ui:2.0:*:*:*:*:netweaver_7.0:*:* | 2.0 | Vulnerable | SAP |
| cpe:2.3:a:sap:ui:7.5:*:*:*:*:*:*:* | 7.5 | Vulnerable | SAP |
| cpe:2.3:a:sap:ui:7.51:*:*:*:*:*:*:* | 7.51 | Vulnerable | SAP |
| cpe:2.3:a:sap:ui:7.52:*:*:*:*:*:*:* | 7.52 | Vulnerable | SAP |
| cpe:2.3:a:sap:ui:7.53:*:*:*:*:*:*:* | 7.53 | Vulnerable | SAP |
| cpe:2.3:a:sap:ui:7.54:*:*:*:*:*:*:* | 7.54 | Vulnerable | SAP |
- cpe:2.3:a:sap:ui:2.0:*:*:*:*:netweaver_7.0:*:* Versions 2.0 Vulnerable ·SAP
- cpe:2.3:a:sap:ui:7.5:*:*:*:*:*:*:* Versions 7.5 Vulnerable ·SAP
- cpe:2.3:a:sap:ui:7.51:*:*:*:*:*:*:* Versions 7.51 Vulnerable ·SAP
- cpe:2.3:a:sap:ui:7.52:*:*:*:*:*:*:* Versions 7.52 Vulnerable ·SAP
- cpe:2.3:a:sap:ui:7.53:*:*:*:*:*:*:* Versions 7.53 Vulnerable ·SAP
- cpe:2.3:a:sap:ui:7.54:*:*:*:*:*:*:* Versions 7.54 Vulnerable ·SAP
Remediation
- Fix · CNA SAP UI (SAP SE) Fixed in 7.5, 7.51, 7.52, 7.53, 7.54
- Fix · CNA SAP UI 700 (SAP SE) Fixed in 2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2019-0388
- 2026-10-03 Alias added: GHSA-x4ph-cq89-6r82
References
More SAP Ui vulnerabilities
- TI-2018-01809 Improper input validation in SAP HANA Database CVSS 3.0CRITICAL 9.8
- TI-2023-16858 Stored Cross-Site Scripting (Stored XSS) vulnerability in SAP UI5 Variant Management CVSS 3.1HIGH 8.2
- TI-2018-01812 Under certain conditions SAP UI5 Handler allows an attacker to access information which… CVSS 3.0MEDIUM 5.3
Sources
- CVE-2019-0388 · CVE Program
- CVE-2019-0388 · NVD
- FIRST EPSS
- GHSA-x4ph-cq89-6r82 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences