An administrator of SAP NetWeaver Application Server Java (J2EE-Framework), (corrected in…
Priority MEDIUM 41Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
An administrator of SAP NetWeaver Application Server Java (J2EE-Framework), (corrected in versions 7.1, 7.2, 7.3, 7.31, 7.4, 7.5), may change privileges for all or some functions in Java Server, and enable users to execute functions, they are not allowed to execute otherwise.
Why it matters now
EPSS 0.01347 71st percentileScored 2026-11-07
Fix Fixed SAP NetWeaver Application Server Java (J2EE-Framework) (SAP SE): 7.1, 7.2, 7.3 +3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP NetWeaver Application Server Java (J2EE-Framework) | before 7.1; before 7.2; before 7.3; before 7.31; before 7.4; before 7.5 | 7.1, 7.2, 7.3, 7.31, 7.4, 7.5 | Patch available | CNA |
- SAP NetWeaver Application Server Java (J2EE-Framework) VendorSAP Affected before 7.1; before 7.2; before 7.3; before 7.31; before 7.4; before 7.5 Fixed in 7.1, 7.2, 7.3, 7.31, 7.4, 7.5 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver_application_server_java:7.1:*:*:*:*:*:*:* | 7.1 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.2:*:*:*:*:*:*:* | 7.2 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.3:*:*:*:*:*:*:* | 7.3 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.4:*:*:*:*:*:*:* | 7.4 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.5:*:*:*:*:*:*:* | 7.5 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_application_server_java:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver_application_server_java:7.1:*:*:*:*:*:*:* Versions 7.1 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.2:*:*:*:*:*:*:* Versions 7.2 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.3:*:*:*:*:*:*:* Versions 7.3 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.4:*:*:*:*:*:*:* Versions 7.4 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.5:*:*:*:*:*:*:* Versions 7.5 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_application_server_java:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
Remediation
- Fix · CNA SAP NetWeaver Application Server Java (J2EE-Framework) (SAP SE) Fixed in 7.1, 7.2, 7.3, 7.31, 7.4, 7.5
Timeline
- 2026-10-02 Threatist record created from CVE-2019-0389
- 2026-10-03 Alias added: GHSA-77cc-2mff-5mxf
References
More SAP Netweaver Application Server Java vulnerabilities
- TI-2020-05139 Missing authentication in SAP NetWeaver AS JAVA KEVCVSS 3.1CRITICAL 10.0
- TI-2016-02146 SQL injection vulnerability in the UDDI server in SAP NetWeaver J2EE Engine 7.40 allows… KEVCVSS 3.1CRITICAL 9.8
- TI-2010-05023 The Invoker Servlet on SAP NetWeaver Application Server Java platforms, possibly before… KEVCVSS 3.1CRITICAL 10.0
- TI-2017-09362 Directory traversal vulnerability in scheduler/ui/js/ffffffffbca41eb4/UIUtilJavaScriptJS… KEVCVSS 3.1HIGH 7.5
- TI-2016-03377 Directory traversal vulnerability in SAP NetWeaver AS Java 7.1 through 7.5 allows remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07786 BC-BMT-BPM-DSK in SAP NetWeaver AS JAVA 7.5 allows remote authenticated users to conduct… KEVCVSS 3.1MEDIUM 6.5
Sources
- CVE-2019-0389 · CVE Program
- CVE-2019-0389 · NVD
- FIRST EPSS
- GHSA-77cc-2mff-5mxf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences