Code injection in https://xtermjs.org/ xterm.js
Priority MEDIUM 44CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-94.
Summary
A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters, aka "Xterm Remote Code Execution Vulnerability." This affects xterm.js.
Why it matters now
EPSS 0.03166 88th percentileScored 2026-11-07
Fix Fixed xterm (npm): 3.8.1, 3.9.2, 3.10.1Red Hat: 3 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| https://xtermjs.org/ | xterm.js | xterm.js | — | No fix listed | CNA |
| — | xterm (npm) | before 3.8.1 | 3.8.1 | Patch available | GHSA-mc23-976p-j42x |
| — | xterm (npm) | 3.9.0 to before 3.9.2 | 3.9.2 | Patch available | GHSA-mc23-976p-j42x |
| — | xterm (npm) | 3.10.0 to before 3.10.1 | 3.10.1 | Patch available | GHSA-mc23-976p-j42x |
- xterm.js Vendorhttps://xtermjs.org/ Affected xterm.js Fixed in — No fix listed CNA
- xterm (npm) Vendor— Affected before 3.8.1 Fixed in 3.8.1 Patch available GHSA-mc23-976p-j42x
- xterm (npm) Vendor— Affected 3.9.0 to before 3.9.2 Fixed in 3.9.2 Patch available GHSA-mc23-976p-j42x
- xterm (npm) Vendor— Affected 3.10.0 to before 3.10.1 Fixed in 3.10.1 Patch available GHSA-mc23-976p-j42x
Remediation
- Fix · GHSA-mc23-976p-j42x xterm (npm) Fixed in 3.8.1 Advisory →
- Fix · GHSA-mc23-976p-j42x xterm (npm) Fixed in 3.9.2 Advisory →
- Fix · GHSA-mc23-976p-j42x xterm (npm) Fixed in 3.10.1 Advisory →
Red Hat 3 advisories
- RHSA-2019:2551 Released 2019-09-05 · Red Hat rating ModerateOpenShift Container Platform 3.9 atomic-openshift-web-console security update
- Red Hat OpenShift Container Platform 3.9 atomic-openshift-web-console-3.9.99-1.git.1.49cd7e9.el7
- RHSA-2019:2552 Released 2019-08-22 · Red Hat rating ModerateOpenShift Container Platform 3.10 atomic-openshift-web-console security update
- Red Hat OpenShift Container Platform 3.10 atomic-openshift-web-console-3.10.163-1.git.1.c3a2131.el7
- RHSA-2019:1422 Released 2019-06-10 · Red Hat rating ModerateOpenShift Container Platform 3.11 atomic-openshift-web-console security update
- Red Hat OpenShift Container Platform 3.11 atomic-openshift-web-console-3.11.104-1.git.1.3c3a7f2.el7
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.10 | Fixed | RHSA-2019:2552 |
| Red Hat OpenShift Container Platform 3.11 | Fixed | RHSA-2019:1422 |
| Red Hat OpenShift Container Platform 3.9 | Fixed | RHSA-2019:2551 |
Not affected: 1 product
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2019-0542
- 2026-10-03 Alias added: GHSA-mc23-976p-j42x
References
Advisory 6
Sources
- CVE-2019-0542 · CVE Program
- CVE-2019-0542 · NVD
- FIRST EPSS
- GHSA-mc23-976p-j42x · GitHub Advisory Database · CC BY 4.0
- CVE-2019-0542 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences