Cisco NX-OS Software Bash Shell Privilege Escalation Vulnerability
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-264.
Summary
A vulnerability in the Bash shell implementation for Cisco NX-OS Software could allow an authenticated, local attacker to escalate their privilege level to root. The attacker must authenticate with valid user credentials. The vulnerability is due to incorrect permissions of a system executable. An attacker could exploit this vulnerability by authenticating to the device and entering a crafted command at the Bash prompt. A successful exploit could allow the attacker to escalate their privilege level to root. Nexus 3000 Series Switches are affected in versions prior to 7.0(3)I7(4). Nexus 3500 Platform Switches are affected in versions prior to 7.0(3)I7(4). Nexus 3600 Platform Switches are affected in versions prior to 7.0(3)F3(5). Nexus 9000 Series Switches in Standalone NX-OS Mode are affected in versions prior to 7.0(3)I7(4). Nexus 9500 R-Series Line Cards and Fabric Modules are affected in versions prior to 7.0(3)F3(5).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cisco | Nexus 3000 Series Switches | before 7.0(3)I7(4) | 7.0(3)I7(4) | Patch available | CNA |
| Cisco | Nexus 3500 Platform Switches | before 7.0(3)I7(4) | 7.0(3)I7(4) | Patch available | CNA |
| Cisco | Nexus 3600 Platform Switches | before 7.0(3)F3(5) | 7.0(3)F3(5) | Patch available | CNA |
| Cisco | Nexus 9000 Series Switches in Standalone NX-OS Mode | before 7.0(3)I7(4) | 7.0(3)I7(4) | Patch available | CNA |
| Cisco | Nexus 9500 R-Series Line Cards and Fabric Modules | before 7.0(3)F3(5) | 7.0(3)F3(5) | Patch available | CNA |
- Nexus 3000 Series Switches VendorCisco Affected before 7.0(3)I7(4) Fixed in 7.0(3)I7(4) Patch available CNA
- Nexus 3500 Platform Switches VendorCisco Affected before 7.0(3)I7(4) Fixed in 7.0(3)I7(4) Patch available CNA
- Nexus 3600 Platform Switches VendorCisco Affected before 7.0(3)F3(5) Fixed in 7.0(3)F3(5) Patch available CNA
- Nexus 9000 Series Switches in Standalone NX-OS Mode VendorCisco Affected before 7.0(3)I7(4) Fixed in 7.0(3)I7(4) Patch available CNA
- Nexus 9500 R-Series Line Cards and Fabric Modules VendorCisco Affected before 7.0(3)F3(5) Fixed in 7.0(3)F3(5) Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:* | before 7.0\(3\)i4\(9\); 7.0\(3\)i5 to before 7.0\(3\)i7\(4\) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:nexus_3000:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:* | 7.0\(3\)i7 to before 7.0\(3\)i7\(4\) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:nexus_3500:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:* | 7.0\(3\)f3\(1\) to before 7.0\(3\)f3\(5\) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:nexus_3600:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_9000:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_9500:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
- cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:* Versions before 7.0\(3\)i4\(9\); 7.0\(3\)i5 to before 7.0\(3\)i7\(4\) Vulnerable ·Cisco
- cpe:2.3:h:cisco:nexus_3000:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:* Versions 7.0\(3\)i7 to before 7.0\(3\)i7\(4\) Vulnerable ·Cisco
- cpe:2.3:h:cisco:nexus_3500:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:* Versions 7.0\(3\)f3\(1\) to before 7.0\(3\)f3\(5\) Vulnerable ·Cisco
- cpe:2.3:h:cisco:nexus_3600:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_9000:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_9500:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
Remediation
- Fix · CNA Nexus 3000 Series Switches (Cisco) Fixed in 7.0(3)I7(4)
- Fix · CNA Nexus 3500 Platform Switches (Cisco) Fixed in 7.0(3)I7(4)
- Fix · CNA Nexus 3600 Platform Switches (Cisco) Fixed in 7.0(3)F3(5)
- Fix · CNA Nexus 9000 Series Switches in Standalone NX-OS Mode (Cisco) Fixed in 7.0(3)I7(4)
- Fix · CNA Nexus 9500 R-Series Line Cards and Fabric Modules (Cisco) Fixed in 7.0(3)F3(5)
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Cisco Nexus 3600 Platform Switches, Nexus 9500 R-Series Line Cards and Fabric Modules 7.0(3)F3(5)
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-01227 Cisco FXOS and NX-OS Software Unauthorized Directory Access VulnerabilityPriority LOW 23
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1596
- 2026-10-03 Alias added: GHSA-gqv4-4m7f-x3p4
More Cisco Nx-os vulnerabilities
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-13332 Cisco NX-OS Software CLI Command Injection Vulnerability KEVCVSS 3.1MEDIUM 6.7
- TI-2018-00260 Improper input validation in Cisco NX-OS unknown CVSS 3.0CRITICAL 9.8
- TI-2019-01226 Cisco NX-OS Software Netstack Denial of Service Vulnerability CVSS 3.1HIGH 8.6
- TI-2022-05183 Cisco NX-OS Software Cisco Fabric Services Over IP Denial of Service Vulnerability CVSS 3.1HIGH 8.6
- TI-2022-05182 Cisco Nexus 9000 Series Switches Bidirectional Forwarding Detection Denial of Service Vulnerability CVSS 3.1HIGH 8.6
Sources
- CVE-2019-1596 · CVE Program
- CVE-2019-1596 · NVD
- FIRST EPSS
- GHSA-gqv4-4m7f-x3p4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences