Read the docs
TI-2019-01308 Aliases CVE-2019-1682GHSA-w5xg-prmx-v5rm

Cisco Application Policy Infrastructure Controller Privilege Escalation Vulnerability

Priority LOW 36CWE-264Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-264.

Summary

A vulnerability in the FUSE filesystem functionality for Cisco Application Policy Infrastructure Controller (APIC) software could allow an authenticated, local attacker to escalate privileges to root on an affected device. The vulnerability is due to insufficient input validation for certain command strings issued on the CLI of the affected device. An attacker with write permissions for files within a readable folder on the device could alter certain definitions in the affected file. A successful exploit could allow an attacker to cause the underlying FUSE driver to execute said crafted commands, elevating the attacker's privileges to root on an affected device.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00352 29th percentileScored 2026-11-07
Fix Fixed Cisco Application Policy Infrastructure Controller (APIC) (Cisco): 4.1(1i)

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
CiscoCisco Application Policy Infrastructure Controller (APIC)before 4.1(1i)4.1(1i)Patch availableCNA
  • Cisco Application Policy Infrastructure Controller (APIC) VendorCisco Affected before 4.1(1i) Fixed in 4.1(1i) Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:cisco:application_policy_infrastructure_controller:*:*:*:*:*:*:*:*before 4.1\(1i\)VulnerableCisco
  • cpe:2.3:a:cisco:application_policy_infrastructure_controller:*:*:*:*:*:*:*:* Versions before 4.1\(1i\) Vulnerable ·Cisco

Remediation

  • Fix · CNA Cisco Application Policy Infrastructure Controller (APIC) (Cisco) Fixed in 4.1(1i)

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Cisco Application Policy Infrastructure Controller (APIC) 4.1(1i)

    3 records Highest priority Priority LOW 3 LOW

    Other records, highest priority first

    • TI-2019-01318 Information disclosure in Cisco Application Policy Infrastructure ControllerPriority LOW 32
    • TI-2019-01461 Cisco Application Policy Infrastructure Controller Web-Based Management Interface Cross-Site Scripting VulnerabilityPriority LOW 26

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-1682
  2. 2026-10-03 Alias added: GHSA-w5xg-prmx-v5rm

References

  • TI-2021-01115 Cisco ACI Multi-Site Orchestrator Application Services Engine Deployment Authentication Bypass Vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2021-01120 Cisco Application Services Engine Unauthorized Access Vulnerabilities CVSS 3.1CRITICAL 9.8
  • TI-2021-01123 Cisco Application Services Engine Unauthorized Access Vulnerabilities CVSS 3.1CRITICAL 9.8
  • TI-2021-01301 Cisco Application Policy Infrastructure Controller Arbitrary File Read and Write Vulnerability CVSS 3.1CRITICAL 9.1
  • TI-2021-01305 Cisco Application Policy Infrastructure Controller Command Injection and File Upload Vulnerabilities CVSS 3.1CRITICAL 9.1
  • TI-2021-01302 Cisco Application Policy Infrastructure Controller Privilege Escalation Vulnerability CVSS 3.1HIGH 8.8
See all 33 →

Sources