Cisco NX-OS Software NX-API Sandbox Cross-Site Scripting Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability in the NX API (NX-API) Sandbox interface for Cisco NX-OS Software could allow an authenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the NX-API Sandbox interface of an affected device. The vulnerability is due to insufficient validation of user-supplied input by the NX-API Sandbox interface. An attacker could exploit this vulnerability by persuading a user of the NX-API Sandbox interface to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected NX-API Sandbox interface.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cisco | Cisco NX-OS Software | before 8.3(1) | 8.3(1) | Patch available | CNA |
- Cisco NX-OS Software VendorCisco Affected before 8.3(1) Fixed in 8.3(1) Patch available CNA
CPE configurations NVD · 17
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:* | 7.0\(3\)i7 to before 7.0\(3\)i7\(4\) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:nexus_3000:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_3100:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_3100-z:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_3100v:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_3200:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_3400:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_3500:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_3524-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_3524-xl:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
- cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:* Versions 7.0\(3\)i7 to before 7.0\(3\)i7\(4\) Vulnerable ·Cisco
- cpe:2.3:h:cisco:nexus_3000:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_3100:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_3100-z:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_3100v:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_3200:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_3400:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_3500:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_3524-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_3524-xl:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
Show 7 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:h:cisco:nexus_3548-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_3548-xl:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_3600:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_9000:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_9200:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_9300:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:nexus_9500:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
- cpe:2.3:h:cisco:nexus_3548-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_3548-xl:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_3600:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_9000:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_9200:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_9300:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:nexus_9500:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
Remediation
- Fix · CNA Cisco NX-OS Software (Cisco) Fixed in 8.3(1)
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Cisco NX-OS Software 8.3(1)
18 records Highest priority Priority LOW 18 LOW
Other records, highest priority first
- TI-2019-01361 Cisco NX-OS Software Command Injection Vulnerability (CVE-2019-1735)Priority LOW 35
- TI-2019-01419 Cisco FXOS and NX-OS Software Command Injection VulnerabilityPriority LOW 32
- TI-2019-01416 Cisco NX-OS Software Command Injection VulnerabilityPriority LOW 32
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1733
- 2026-10-03 Alias added: GHSA-qppv-v6vq-jq33
References
More Cisco Nx-os vulnerabilities
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2024-13332 Cisco NX-OS Software CLI Command Injection Vulnerability KEVCVSS 3.1MEDIUM 6.7
- TI-2018-00260 Improper input validation in Cisco NX-OS unknown CVSS 3.0CRITICAL 9.8
- TI-2019-01226 Cisco NX-OS Software Netstack Denial of Service Vulnerability CVSS 3.1HIGH 8.6
- TI-2022-05183 Cisco NX-OS Software Cisco Fabric Services Over IP Denial of Service Vulnerability CVSS 3.1HIGH 8.6
- TI-2022-05182 Cisco Nexus 9000 Series Switches Bidirectional Forwarding Detection Denial of Service Vulnerability CVSS 3.1HIGH 8.6
Sources
- CVE-2019-1733 · CVE Program
- CVE-2019-1733 · NVD
- FIRST EPSS
- GHSA-qppv-v6vq-jq33 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences