Cisco Integrated Management Controller Command Injection Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
A vulnerability in the web-based management interface of Cisco Integrated Management Controller (IMC) Software could allow an authenticated, remote attacker to inject arbitrary commands that are executed with root privileges on an affected device. The vulnerability is due to insufficient validation of user-supplied input by the affected software. An attacker could exploit this vulnerability by invoking an interface monitoring mechanism with a crafted argument on the affected software. A successful exploit could allow the attacker to inject and execute arbitrary, system-level commands with root privileges on an affected device.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cisco | Cisco Unified Computing System E-Series Software (UCSE) | before 2.0(13o) | 2.0(13o) | Patch available | CNA |
- Cisco Unified Computing System E-Series Software (UCSE) VendorCisco Affected before 2.0(13o) Fixed in 2.0(13o) Patch available CNA
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cisco:unified_computing_system:4.0\(1c\)hs3:*:*:*:*:*:*:* | 4.0(1c)hs3 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:integrated_management_controller_supervisor:*:*:*:*:*:*:*:* | 1.5.0.0 to before 1.5\(9g\); 2.0.0.0 to before 2.0\(13o\); 3.0.0.0 to before 3.0\(4k\); 4.0.0.0 to before 4.0\(4b\) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:encs_5100:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:encs_5400:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:ucs-e1120d-m3:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:ucs-e140s-m2:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:ucs-e160d-m2:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:ucs-e160s-m3:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:ucs-e168d-m2:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:ucs-e180d-m3:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
- cpe:2.3:a:cisco:unified_computing_system:4.0\(1c\)hs3:*:*:*:*:*:*:* Versions 4.0(1c)hs3 Vulnerable ·Cisco
- cpe:2.3:a:cisco:integrated_management_controller_supervisor:*:*:*:*:*:*:*:* Versions 1.5.0.0 to before 1.5\(9g\); 2.0.0.0 to before 2.0\(13o\); 3.0.0.0 to before 3.0\(4k\); 4.0.0.0 to before 4.0\(4b\) Vulnerable ·Cisco
- cpe:2.3:h:cisco:encs_5100:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:encs_5400:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:ucs-e1120d-m3:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:ucs-e140s-m2:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:ucs-e160d-m2:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:ucs-e160s-m3:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:ucs-e168d-m2:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:ucs-e180d-m3:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:h:cisco:ucs_c125_m5:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:ucs_c4200:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:h:cisco:ucs_s3260:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:a:cisco:integrated_management_controller_supervisor:*:*:*:*:*:*:*:* | 4.0.0.0 to before 4.0\(1d\); 4.0.0.0 to before 4.0\(2c\) | Vulnerable | Cisco |
- cpe:2.3:h:cisco:ucs_c125_m5:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:ucs_c4200:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:h:cisco:ucs_s3260:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:a:cisco:integrated_management_controller_supervisor:*:*:*:*:*:*:*:* Versions 4.0.0.0 to before 4.0\(1d\); 4.0.0.0 to before 4.0\(2c\) Vulnerable ·Cisco
Remediation
- Fix · CNA Cisco Unified Computing System E-Series Software (UCSE) (Cisco) Fixed in 2.0(13o)
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Cisco Unified Computing System E-Series Software (UCSE) 2.0(13o)
4 records Highest priority Priority MEDIUM 2 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2019-01486 Cisco Integrated Management Controller Command Injection VulnerabilityPriority MEDIUM 45
- TI-2019-01485 Cisco Integrated Management Controller Privilege Escalation VulnerabilityPriority LOW 39
- TI-2019-01260 Cisco Integrated Management Controller Command Injection VulnerabilityPriority LOW 39
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1865
- 2026-10-03 Alias added: GHSA-3xrf-vrqp-mvm5
References
More Cisco Integrated Management Controller Supervisor vulnerabilities
- TI-2021-19919 Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints KEVCVSS 3.1CRITICAL 10.0
- TI-2019-01555 Hard-coded credentials in Cisco Unified Computing System Director CVSS 3.1CRITICAL 9.8
- TI-2019-01557 Improper authentication in Cisco Unified Computing System Director CVSS 3.0CRITICAL 9.8
- TI-2019-01556 Improper input validation in Cisco Unified Computing System Director CVSS 3.1HIGH 7.2
- TI-2019-01594 Improper authentication in Cisco Unified Computing System Director CVSS 3.0CRITICAL 9.8
- TI-2015-05250 The JavaServer Pages (JSP) component in Cisco Integrated Management Controller (IMC)… CVSS 2.0HIGH 9.4
Sources
- CVE-2019-1865 · CVE Program
- CVE-2019-1865 · NVD
- FIRST EPSS
- GHSA-3xrf-vrqp-mvm5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences