Cisco ASA and FTD Software Cryptographic TLS and SSL Driver Denial of Service Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-400.
Summary
A vulnerability in the cryptographic driver for Cisco Adaptive Security Appliance Software (ASA) and Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to cause the device to reboot unexpectedly. The vulnerability is due to incomplete input validation of a Secure Sockets Layer (SSL) or Transport Layer Security (TLS) ingress packet header. An attacker could exploit this vulnerability by sending a crafted TLS/SSL packet to an interface on the targeted device. An exploit could allow the attacker to cause the device to reload, which will result in a denial of service (DoS) condition. Note: Only traffic directed to the affected system can be used to exploit this vulnerability. This vulnerability affects systems configured in routed and transparent firewall mode and in single or multiple context mode. This vulnerability can be triggered by IPv4 and IPv6 traffic. A valid SSL or TLS session is required to exploit this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cisco | Cisco Adaptive Security Appliance (ASA) Software | before 9.4.4.36; before 9.6.4.29; before 9.8.4.3; before 9.9.2.52; before 9.10.1.22; before 9.12.2 | 9.4.4.36, 9.6.4.29, 9.8.4.3, 9.9.2.52, 9.10.1.22, 9.12.2 | Patch available | CNA |
- Cisco Adaptive Security Appliance (ASA) Software VendorCisco Affected before 9.4.4.36; before 9.6.4.29; before 9.8.4.3; before 9.9.2.52; before 9.10.1.22; before 9.12.2 Fixed in 9.4.4.36, 9.6.4.29, 9.8.4.3, 9.9.2.52, 9.10.1.22, 9.12.2 Patch available CNA
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:cisco:asa_5506-x_firmware:9.6\(4.16\):*:*:*:*:*:*:* | 9.6(4.16) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:asa_5506-x_firmware:9.8\(3.8\):*:*:*:*:*:*:* | 9.8(3.8) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:asa_5506-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:asa_5506h-x_firmware:9.6\(4.16\):*:*:*:*:*:*:* | 9.6(4.16) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:asa_5506h-x_firmware:9.8\(3.8\):*:*:*:*:*:*:* | 9.8(3.8) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:asa_5506h-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:asa_5506w-x_firmware:9.6\(4.16\):*:*:*:*:*:*:* | 9.6(4.16) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:asa_5506w-x_firmware:9.8\(3.8\):*:*:*:*:*:*:* | 9.8(3.8) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:asa_5506w-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:asa_5508-x_firmware:9.6\(4.16\):*:*:*:*:*:*:* | 9.6(4.16) | Vulnerable | Cisco |
- cpe:2.3:o:cisco:asa_5506-x_firmware:9.6\(4.16\):*:*:*:*:*:*:* Versions 9.6(4.16) Vulnerable ·Cisco
- cpe:2.3:o:cisco:asa_5506-x_firmware:9.8\(3.8\):*:*:*:*:*:*:* Versions 9.8(3.8) Vulnerable ·Cisco
- cpe:2.3:h:cisco:asa_5506-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:asa_5506h-x_firmware:9.6\(4.16\):*:*:*:*:*:*:* Versions 9.6(4.16) Vulnerable ·Cisco
- cpe:2.3:o:cisco:asa_5506h-x_firmware:9.8\(3.8\):*:*:*:*:*:*:* Versions 9.8(3.8) Vulnerable ·Cisco
- cpe:2.3:h:cisco:asa_5506h-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:asa_5506w-x_firmware:9.6\(4.16\):*:*:*:*:*:*:* Versions 9.6(4.16) Vulnerable ·Cisco
- cpe:2.3:o:cisco:asa_5506w-x_firmware:9.8\(3.8\):*:*:*:*:*:*:* Versions 9.8(3.8) Vulnerable ·Cisco
- cpe:2.3:h:cisco:asa_5506w-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:asa_5508-x_firmware:9.6\(4.16\):*:*:*:*:*:*:* Versions 9.6(4.16) Vulnerable ·Cisco
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:cisco:asa_5508-x_firmware:9.8\(3.8\):*:*:*:*:*:*:* | 9.8(3.8) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:asa_5508-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
| cpe:2.3:o:cisco:asa_5516-x_firmware:9.6\(4.16\):*:*:*:*:*:*:* | 9.6(4.16) | Vulnerable | Cisco |
| cpe:2.3:o:cisco:asa_5516-x_firmware:9.8\(3.8\):*:*:*:*:*:*:* | 9.8(3.8) | Vulnerable | Cisco |
| cpe:2.3:h:cisco:asa_5516-x:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Cisco |
- cpe:2.3:o:cisco:asa_5508-x_firmware:9.8\(3.8\):*:*:*:*:*:*:* Versions 9.8(3.8) Vulnerable ·Cisco
- cpe:2.3:h:cisco:asa_5508-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
- cpe:2.3:o:cisco:asa_5516-x_firmware:9.6\(4.16\):*:*:*:*:*:*:* Versions 9.6(4.16) Vulnerable ·Cisco
- cpe:2.3:o:cisco:asa_5516-x_firmware:9.8\(3.8\):*:*:*:*:*:*:* Versions 9.8(3.8) Vulnerable ·Cisco
- cpe:2.3:h:cisco:asa_5516-x:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Cisco
Remediation
- Fix · CNA Cisco Adaptive Security Appliance (ASA) Software (Cisco) Fixed in 9.4.4.36, 9.6.4.29, 9.8.4.3, 9.9.2.52, 9.10.1.22, 9.12.2
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1873
- 2026-10-03 Alias added: GHSA-q443-v72w-7x2v
References
Sources
- CVE-2019-1873 · CVE Program
- CVE-2019-1873 · NVD
- FIRST EPSS
- GHSA-q443-v72w-7x2v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences