Cisco Web Security Appliance Web Proxy Denial of Service Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA.
Summary
A vulnerability in the web proxy functionality of Cisco AsyncOS Software for Cisco Web Security Appliance (WSA) could allow an authenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. The vulnerability is due to insufficient input validation mechanisms for certain fields in HTTP/HTTPS requests sent through an affected device. A successful attacker could exploit this vulnerability by sending a malicious HTTP/HTTPS request through an affected device. An exploit could allow the attacker to force the device to stop processing traffic, resulting in a DoS condition.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cisco | Cisco Web Security Appliance (WSA) | before 10.5.5-005 | 10.5.5-005 | Patch available | CNA |
- Cisco Web Security Appliance (WSA) VendorCisco Affected before 10.5.5-005 Fixed in 10.5.5-005 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:cisco:asyncos:*:*:*:*:*:*:*:* | 10.1 to before 10.5.5-005; 11.5 to before 11.5.2-020; 11.7 to before 11.7.0-407 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:10.1.4-017:*:*:*:*:*:*:* | 10.1.4-017 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:10.5.2-072:*:*:*:*:*:*:* | 10.5.2-072 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:11.5.1-fcs-125:*:*:*:*:*:*:* | 11.5.1-fcs-125 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:web_security_appliance:11.7.0-256:*:*:*:*:*:*:* | 11.7.0-256 | Vulnerable | Cisco |
- cpe:2.3:o:cisco:asyncos:*:*:*:*:*:*:*:* Versions 10.1 to before 10.5.5-005; 11.5 to before 11.5.2-020; 11.7 to before 11.7.0-407 Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:10.1.4-017:*:*:*:*:*:*:* Versions 10.1.4-017 Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:10.5.2-072:*:*:*:*:*:*:* Versions 10.5.2-072 Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:11.5.1-fcs-125:*:*:*:*:*:*:* Versions 11.5.1-fcs-125 Vulnerable ·Cisco
- cpe:2.3:a:cisco:web_security_appliance:11.7.0-256:*:*:*:*:*:*:* Versions 11.7.0-256 Vulnerable ·Cisco
Remediation
- Fix · CNA Cisco Web Security Appliance (WSA) (Cisco) Fixed in 10.5.5-005
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Cisco Web Security Appliance (WSA) 10.5.5-005
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2019-01508 Cisco Web Security Appliance HTTPS Certificate Denial of Service VulnerabilityPriority MEDIUM 46
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1884
- 2026-10-03 Alias added: GHSA-jpm3-6rm2-fhgg
References
More Cisco Asyncos vulnerabilities
- TI-2026-74174 Arbitrary file write in Cisco Secure Email Gateway via AMP feature KEVCVSS 3.1CRITICAL 9.8
- TI-2026-53489 Cisco Secure Email Gateway SQL Injection Vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2025-14683 Cisco Secure Email Gateway and Cisco Secure Email and Web Manager Remote Command Execution Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2021-13698 Cisco Web Security Appliance Proxy Service Denial of Service Vulnerability CVSS 3.1HIGH 8.6
- TI-2018-11020 Cisco Email Security Appliance URL Filtering Denial of Service Vulnerability CVSS 3.1HIGH 8.6
- TI-2019-01567 Cisco Email Security Appliance Denial of Service Vulnerability CVSS 3.1HIGH 8.6
Sources
- CVE-2019-1884 · CVE Program
- CVE-2019-1884 · NVD
- FIRST EPSS
- GHSA-jpm3-6rm2-fhgg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences