Cisco Firepower Management Center RSS Cross-Site Scripting Vulnerabilities
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Multiple vulnerabilities in the RSS dashboard in the web-based management interface of Cisco Firepower Management Center (FMC) could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the web-based management interface of an affected device. The vulnerabilities are due to insufficient validation of user-supplied input by the web-based management interface of the affected device. An attacker could exploit these vulnerabilities by persuading a user of the interface to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cisco | Cisco Firepower Management Center | before 6.2.3.14 | 6.2.3.14 | Patch available | CNA |
- Cisco Firepower Management Center VendorCisco Affected before 6.2.3.14 Fixed in 6.2.3.14 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cisco:secure_firewall_management_center:6.2.3:*:*:*:*:*:*:* | 6.2.3 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:secure_firewall_management_center:6.3.0:*:*:*:*:*:*:* | 6.3.0 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:secure_firewall_management_center:6.4.0:*:*:*:*:*:*:* | 6.4.0 | Vulnerable | Cisco |
| cpe:2.3:a:cisco:secure_firewall_management_center:6.5.0:*:*:*:*:*:*:* | 6.5.0 | Vulnerable | Cisco |
- cpe:2.3:a:cisco:secure_firewall_management_center:6.2.3:*:*:*:*:*:*:* Versions 6.2.3 Vulnerable ·Cisco
- cpe:2.3:a:cisco:secure_firewall_management_center:6.3.0:*:*:*:*:*:*:* Versions 6.3.0 Vulnerable ·Cisco
- cpe:2.3:a:cisco:secure_firewall_management_center:6.4.0:*:*:*:*:*:*:* Versions 6.4.0 Vulnerable ·Cisco
- cpe:2.3:a:cisco:secure_firewall_management_center:6.5.0:*:*:*:*:*:*:* Versions 6.5.0 Vulnerable ·Cisco
Remediation
- Fix · CNA Cisco Firepower Management Center (Cisco) Fixed in 6.2.3.14
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Cisco Firepower Management Center — 20190703 Cisco Firepower Management Center RSS Cross-Site Scripting Vulnerabilities
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-01551 Cisco Firepower Management Center RSS Cross-Site Scripting VulnerabilitiesPriority LOW 29
Timeline
- 2026-10-02 Threatist record created from CVE-2019-1930
- 2026-10-03 Alias added: GHSA-w9gf-5vj3-683v
References
More Cisco Secure Firewall Management Center vulnerabilities
- TI-2026-16344 Cisco Secure Firewall Management Center Software Remote Code Execution Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2026-16292 Cisco Secure Firewall Management Center Authentication Bypass Remote Code Execution Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2026-16502 Cisco Secure Firewall Management Center Software Static Credential Vulnerability KEVCVSS 3.1MEDIUM 5.3
- TI-2016-05515 The Threat Management Console in Cisco Firepower Management Center 5.2.0 through 6.0.1… CVSS 3.1HIGH 8.8
- TI-2025-14563 Cisco Secure Firewall Management Center Software Radius Remote Code Execution Vulnerability CVSS 3.1CRITICAL 10.0
- TI-2023-06757 Improper privilege management in Cisco Firepower Management Center CVSS 3.1CRITICAL 9.9
Sources
- CVE-2019-1930 · CVE Program
- CVE-2019-1930 · NVD
- FIRST EPSS
- GHSA-w9gf-5vj3-683v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences