Read the docs
TI-2019-01561 Aliases CVE-2019-1941GHSA-9h55-wh2g-9x6v

Cisco Identity Services Engine Cross-Site Scripting Vulnerability

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

A vulnerability in the web-based management interface of Cisco Identity Services Engine (ISE) could allow an unauthenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the web-based management interface of an affected device. The vulnerability exists because the web-based management interface does not properly validate user-supplied input. An attacker could exploit this vulnerability by persuading a user to click a malicious link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected interface or access sensitive, browser-based information. At the time of publication, this vulnerability affected Cisco ISE running software releases prior to 2.4.0 Patch 9 and 2.6.0.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01271 70th percentileScored 2026-11-07
Fix Fixed Cisco Identity Services Engine Software (Cisco): 2.6.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
CiscoCisco Identity Services Engine Softwarebefore 2.6.02.6.0Patch availableCNA
  • Cisco Identity Services Engine Software VendorCisco Affected before 2.6.0 Fixed in 2.6.0 Patch available CNA

CPE configurations NVD · 10

CPEVersionsRoleVendor
cpe:2.3:a:cisco:identity_services_engine:*:*:*:*:*:*:*:*before 2.4.0VulnerableCisco
cpe:2.3:a:cisco:identity_services_engine:2.4\(0.902\):*:*:*:*:*:*:*2.4(0.902)VulnerableCisco
cpe:2.3:a:cisco:identity_services_engine:2.4.0:patch_1:*:*:*:*:*:*2.4.0 patch_1VulnerableCisco
cpe:2.3:a:cisco:identity_services_engine:2.4.0:patch_2:*:*:*:*:*:*2.4.0 patch_2VulnerableCisco
cpe:2.3:a:cisco:identity_services_engine:2.4.0:patch_3:*:*:*:*:*:*2.4.0 patch_3VulnerableCisco
cpe:2.3:a:cisco:identity_services_engine:2.4.0:patch_5:*:*:*:*:*:*2.4.0 patch_5VulnerableCisco
cpe:2.3:a:cisco:identity_services_engine:2.4.0:patch_6:*:*:*:*:*:*2.4.0 patch_6VulnerableCisco
cpe:2.3:a:cisco:identity_services_engine:2.4.0:patch_7:*:*:*:*:*:*2.4.0 patch_7VulnerableCisco
cpe:2.3:a:cisco:identity_services_engine:2.4.0:patch_8:*:*:*:*:*:*2.4.0 patch_8VulnerableCisco
cpe:2.3:a:cisco:identity_services_engine:2.5\(0.225\):*:*:*:*:*:*:*2.5(0.225)VulnerableCisco
  • cpe:2.3:a:cisco:identity_services_engine:*:*:*:*:*:*:*:* Versions before 2.4.0 Vulnerable ·Cisco
  • cpe:2.3:a:cisco:identity_services_engine:2.4\(0.902\):*:*:*:*:*:*:* Versions 2.4(0.902) Vulnerable ·Cisco
  • cpe:2.3:a:cisco:identity_services_engine:2.4.0:patch_1:*:*:*:*:*:* Versions 2.4.0 patch_1 Vulnerable ·Cisco
  • cpe:2.3:a:cisco:identity_services_engine:2.4.0:patch_2:*:*:*:*:*:* Versions 2.4.0 patch_2 Vulnerable ·Cisco
  • cpe:2.3:a:cisco:identity_services_engine:2.4.0:patch_3:*:*:*:*:*:* Versions 2.4.0 patch_3 Vulnerable ·Cisco
  • cpe:2.3:a:cisco:identity_services_engine:2.4.0:patch_5:*:*:*:*:*:* Versions 2.4.0 patch_5 Vulnerable ·Cisco
  • cpe:2.3:a:cisco:identity_services_engine:2.4.0:patch_6:*:*:*:*:*:* Versions 2.4.0 patch_6 Vulnerable ·Cisco
  • cpe:2.3:a:cisco:identity_services_engine:2.4.0:patch_7:*:*:*:*:*:* Versions 2.4.0 patch_7 Vulnerable ·Cisco
  • cpe:2.3:a:cisco:identity_services_engine:2.4.0:patch_8:*:*:*:*:*:* Versions 2.4.0 patch_8 Vulnerable ·Cisco
  • cpe:2.3:a:cisco:identity_services_engine:2.5\(0.225\):*:*:*:*:*:*:* Versions 2.5(0.225) Vulnerable ·Cisco

Remediation

  • Fix · CNA Cisco Identity Services Engine Software (Cisco) Fixed in 2.6.0

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Cisco Identity Services Engine Software 2.6.0

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2019-01562 Cisco Identity Services Engine Blind SQL Injection VulnerabilityPriority LOW 31

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-1941
  2. 2026-10-03 Alias added: GHSA-9h55-wh2g-9x6v

References

  • TI-2026-53488 Cisco Identity Services Engine Authentication Bypass Vulnerability KEVCVSS 3.1CRITICAL 10.0
  • TI-2025-14632 Cisco ISE API Unauthenticated Remote Code Execution Vulnerability KEVCVSS 3.1CRITICAL 10.0
  • TI-2025-14578 Cisco ISE API Unauthenticated Remote Code Execution Vulnerability KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-19919 Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints KEVCVSS 3.1CRITICAL 10.0
  • TI-2025-14579 Cisco ISE API Unauthenticated Remote Code Execution Vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2022-05522 OS command injection in Cisco Identity Services Engine Software CVSS 3.1HIGH 8.8
See all 197 →

Sources