Improper access control in Oracle MySQL Connectors
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
Vulnerability in the MySQL Connectors component of Oracle MySQL (subcomponent: Connector/Python). Supported versions that are affected are 8.0.13 and prior and 2.1.8 and prior. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise MySQL Connectors. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all MySQL Connectors accessible data as well as unauthorized access to critical data or complete access to all MySQL Connectors accessible data. CVSS 3.0 Base Score 8.1 (Confidentiality and Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Oracle | MySQL Connectors | up to 8.0.13; up to 2.1.8 | — | No fix listed | CNA |
| — | mysql-connector-python (PyPI) | 8.0.0 to before 8.0.19 | 8.0.19 | Patch available | GHSA-v5rq-w2xm-7g5f |
| — | mysql-connector-python (PyPI) | 2.1.0 – 2.1.8 | — | No fix listed | GHSA-v5rq-w2xm-7g5f |
- MySQL Connectors VendorOracle Affected up to 8.0.13; up to 2.1.8 Fixed in — No fix listed CNA
- mysql-connector-python (PyPI) Vendor— Affected 8.0.0 to before 8.0.19 Fixed in 8.0.19 Patch available GHSA-v5rq-w2xm-7g5f
- mysql-connector-python (PyPI) Vendor— Affected 2.1.0 – 2.1.8 Fixed in — No fix listed GHSA-v5rq-w2xm-7g5f
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:oracle:mysql_connectors:*:*:*:*:*:*:*:* | 2.1.0 – 2.1.8; 8.0.0 – 8.0.13 | Vulnerable | Oracle |
| cpe:2.3:a:netapp:active_iq_unified_manager:*:*:*:*:*:windows:*:* | 7.3 | Vulnerable | NetApp |
| cpe:2.3:a:netapp:active_iq_unified_manager:*:*:*:*:*:vsphere:*:* | 9.5 | Vulnerable | NetApp |
| cpe:2.3:a:netapp:oncommand_workflow_automation:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
| cpe:2.3:a:netapp:snapcenter:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | NetApp |
- cpe:2.3:a:oracle:mysql_connectors:*:*:*:*:*:*:*:* Versions 2.1.0 – 2.1.8; 8.0.0 – 8.0.13 Vulnerable ·Oracle
- cpe:2.3:a:netapp:active_iq_unified_manager:*:*:*:*:*:windows:*:* Versions 7.3 Vulnerable ·NetApp
- cpe:2.3:a:netapp:active_iq_unified_manager:*:*:*:*:*:vsphere:*:* Versions 9.5 Vulnerable ·NetApp
- cpe:2.3:a:netapp:oncommand_workflow_automation:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
- cpe:2.3:a:netapp:snapcenter:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
Remediation
- Fix · GHSA-v5rq-w2xm-7g5f mysql-connector-python (PyPI) Fixed in 8.0.19 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-2435
- 2026-10-03 Alias added: GHSA-v5rq-w2xm-7g5f
References
Advisory 4
More Oracle Mysql Connectors vulnerabilities
- TI-2021-02645 SM2 Decryption Buffer Overflow CVSS 3.1CRITICAL 9.8
- TI-2020-01888 Segmentation fault in SSL_check_chain CVSS 3.1HIGH 7.5
- TI-2021-02413 NULL pointer deref in signature_algorithms processing CVSS 3.1MEDIUM 5.9
- TI-2021-02646 Read buffer overruns processing ASN.1 strings CVSS 3.1HIGH 7.4
- TI-2021-02414 CA certificate check bypass with X509_V_FLAG_X509_STRICT CVSS 3.1HIGH 7.4
- TI-2022-06195 Prototype pollution in NodeJS Node CVSS 3.1HIGH 8.2
Sources
- CVE-2019-2435 · CVE Program
- CVE-2019-2435 · NVD
- FIRST EPSS
- GHSA-v5rq-w2xm-7g5f · GitHub Advisory Database · CC BY 4.0
- CVE-2019-2435 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences