Read the docs
TI-2019-02593 Aliases CVE-2019-3465GHSA-pqm6-cgwr-x6pf

Improper signature verification in Rob Richards XmlSecLibs

Priority MEDIUM 43CWE-347Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-347.

Summary

Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.

Why it matters now

EPSS 0.02988 87th percentileScored 2026-11-07
Fix Fixed robrichards/xmlseclibs (Packagist): 3.0.4, 2.1.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Rob Richards XmlSecLibsAll versions prior to version 3.0.3—No fix listedCNA
—robrichards/xmlseclibs (Packagist)3.0.0 to before 3.0.43.0.4Patch availableGHSA-pqm6-cgwr-x6pf
—robrichards/xmlseclibs (Packagist)1.0.0 to before 2.1.12.1.1Patch availableGHSA-pqm6-cgwr-x6pf
  • Rob Richards XmlSecLibs Vendor— Affected All versions prior to version 3.0.3 Fixed in — No fix listed CNA
  • robrichards/xmlseclibs (Packagist) Vendor— Affected 3.0.0 to before 3.0.4 Fixed in 3.0.4 Patch available GHSA-pqm6-cgwr-x6pf
  • robrichards/xmlseclibs (Packagist) Vendor— Affected 1.0.0 to before 2.1.1 Fixed in 2.1.1 Patch available GHSA-pqm6-cgwr-x6pf

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:xmlseclibs_project:xmlseclibs:*:*:*:*:*:*:*:*1.0.0 – 1.4.2; 2.0.0 – 2.1.0; 3.0.0 – 3.0.3VulnerableXmlseclibs Project
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:*up to 1.17.6Vulnerablesimplesamlphp
  • cpe:2.3:a:xmlseclibs_project:xmlseclibs:*:*:*:*:*:*:*:* Versions 1.0.0 – 1.4.2; 2.0.0 – 2.1.0; 3.0.0 – 3.0.3 Vulnerable ·Xmlseclibs Project
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
  • cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* Versions up to 1.17.6 Vulnerable ·simplesamlphp

Remediation

  • Fix · GHSA-pqm6-cgwr-x6pf robrichards/xmlseclibs (Packagist) Fixed in 3.0.4 Advisory →
  • Fix · GHSA-pqm6-cgwr-x6pf robrichards/xmlseclibs (Packagist) Fixed in 2.1.1 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-3465
  2. 2026-10-03 Alias added: GHSA-pqm6-cgwr-x6pf

References

Sources