osc: stores downloaded (supposed) RPM in network-controlled filesystem paths
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A External Control of File Name or Path vulnerability in osc of SUSE Linux Enterprise Module for Development Tools 15, SUSE Linux Enterprise Software Development Kit 12-SP5, SUSE Linux Enterprise Software Development Kit 12-SP4; openSUSE Leap 15.1, openSUSE Factory allowed remote attackers that can change downloaded packages to overwrite arbitrary files. This issue affects: SUSE Linux Enterprise Module for Development Tools 15 osc versions prior to 0.169.1-3.20.1. SUSE Linux Enterprise Software Development Kit 12-SP5 osc versions prior to 0.162.1-15.9.1. SUSE Linux Enterprise Software Development Kit 12-SP4 osc versions prior to 0.162.1-15.9.1. openSUSE Leap 15.1 osc versions prior to 0.169.1-lp151.2.15.1. openSUSE Factory osc versions prior to 0.169.0 .
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | SUSE Linux Enterprise Module for Development Tools 15 | osc to before 0.169.1-3.20.1 | 0.169.1-3.20.1 | Patch available | CNA |
| SUSE | SUSE Linux Enterprise Software Development Kit 12-SP5 | osc to before 0.162.1-15.9.1 | 0.162.1-15.9.1 | Patch available | CNA |
| SUSE | SUSE Linux Enterprise Software Development Kit 12-SP4 | osc to before 0.162.1-15.9.1 | 0.162.1-15.9.1 | Patch available | CNA |
| openSUSE | openSUSE Leap 15.1 | osc to before 0.169.1-lp151.2.15.1 | 0.169.1-lp151.2.15.1 | Patch available | CNA |
| openSUSE | openSUSE Factory | osc to before 0.169.0 | 0.169.0 | Patch available | CNA |
- SUSE Linux Enterprise Module for Development Tools 15 VendorSUSE Affected osc to before 0.169.1-3.20.1 Fixed in 0.169.1-3.20.1 Patch available CNA
- SUSE Linux Enterprise Software Development Kit 12-SP5 VendorSUSE Affected osc to before 0.162.1-15.9.1 Fixed in 0.162.1-15.9.1 Patch available CNA
- SUSE Linux Enterprise Software Development Kit 12-SP4 VendorSUSE Affected osc to before 0.162.1-15.9.1 Fixed in 0.162.1-15.9.1 Patch available CNA
- openSUSE Leap 15.1 VendoropenSUSE Affected osc to before 0.169.1-lp151.2.15.1 Fixed in 0.169.1-lp151.2.15.1 Patch available CNA
- openSUSE Factory VendoropenSUSE Affected osc to before 0.169.0 Fixed in 0.169.0 Patch available CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opensuse:osc:*:*:*:*:*:*:*:* | before 0.169.1-3.20.1 | Vulnerable | openSUSE |
| cpe:2.3:o:suse:linux_enterprise_server:15:*:*:*:*:*:*:* | 15 | Running on | SUSE |
| cpe:2.3:a:opensuse:osc:*:*:*:*:*:*:*:* | before 0.162.1-15.9.1 | Vulnerable | openSUSE |
| cpe:2.3:o:suse:linux_enterprise_software_development_kit:12:sp5:*:*:*:*:*:* | 12 sp5 | Running on | SUSE |
| cpe:2.3:o:suse:linux_enterprise_software_development_kit:12:sp4:*:*:*:*:*:* | 12 sp4 | Running on | SUSE |
| cpe:2.3:a:opensuse:osc:*:*:*:*:*:*:*:* | before 0.169.1-lp151.2.15.1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Running on | openSUSE |
| cpe:2.3:a:opensuse:osc:*:*:*:*:*:*:*:* | before 0.169.0 | Vulnerable | openSUSE |
| cpe:2.3:a:opensuse:factory:-:*:*:*:*:*:*:* | not specified by NVD | Running on | openSUSE |
- cpe:2.3:a:opensuse:osc:*:*:*:*:*:*:*:* Versions before 0.169.1-3.20.1 Vulnerable ·openSUSE
- cpe:2.3:o:suse:linux_enterprise_server:15:*:*:*:*:*:*:* Versions 15 Running on ·SUSE
- cpe:2.3:a:opensuse:osc:*:*:*:*:*:*:*:* Versions before 0.162.1-15.9.1 Vulnerable ·openSUSE
- cpe:2.3:o:suse:linux_enterprise_software_development_kit:12:sp5:*:*:*:*:*:* Versions 12 sp5 Running on ·SUSE
- cpe:2.3:o:suse:linux_enterprise_software_development_kit:12:sp4:*:*:*:*:*:* Versions 12 sp4 Running on ·SUSE
- cpe:2.3:a:opensuse:osc:*:*:*:*:*:*:*:* Versions before 0.169.1-lp151.2.15.1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Running on ·openSUSE
- cpe:2.3:a:opensuse:osc:*:*:*:*:*:*:*:* Versions before 0.169.0 Vulnerable ·openSUSE
- cpe:2.3:a:opensuse:factory:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·openSUSE
Remediation
- Fix · CNA SUSE Linux Enterprise Module for Development Tools 15 (SUSE) Fixed in 0.169.1-3.20.1
- Fix · CNA SUSE Linux Enterprise Software Development Kit 12-SP5 (SUSE) Fixed in 0.162.1-15.9.1
- Fix · CNA SUSE Linux Enterprise Software Development Kit 12-SP4 (SUSE) Fixed in 0.162.1-15.9.1
- Fix · CNA openSUSE Leap 15.1 (openSUSE) Fixed in 0.169.1-lp151.2.15.1
- Fix · CNA openSUSE Factory (openSUSE) Fixed in 0.169.0
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2019-3681
- 2026-10-03 Alias added: GHSA-9w8p-3cm4-h4c7
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-3681 · CVE Program
- CVE-2019-3681 · NVD
- FIRST EPSS
- GHSA-9w8p-3cm4-h4c7 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-3681 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences