Local privilege escalation from user munge to root
Priority LOW 35CWE-59Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A Symbolic Link (Symlink) Following vulnerability in the packaging of munge in SUSE Linux Enterprise Server 15; openSUSE Factory allowed local attackers to escalate privileges from user munge to root. This issue affects: SUSE Linux Enterprise Server 15 munge versions prior to 0.5.13-4.3.1. openSUSE Factory munge versions prior to 0.5.13-6.1.
Why it matters now
EPSS 0.00519 44th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed SUSE Linux Enterprise Server 15 (SUSE): 0.5.13-4.3.1Factory (openSUSE): 0.5.13-6.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | SUSE Linux Enterprise Server 15 | munge to before 0.5.13-4.3.1 | 0.5.13-4.3.1 | Patch available | CNA |
| openSUSE | Factory | munge to before 0.5.13-6.1 | 0.5.13-6.1 | Patch available | CNA |
- SUSE Linux Enterprise Server 15 VendorSUSE Affected munge to before 0.5.13-4.3.1 Fixed in 0.5.13-4.3.1 Patch available CNA
- Factory VendoropenSUSE Affected munge to before 0.5.13-6.1 Fixed in 0.5.13-6.1 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:opensuse:munge:*:*:*:*:*:*:*:* | before 0.5.13-4.3.1 | Vulnerable | openSUSE |
| cpe:2.3:o:suse:suse_linux_enterprise_server:15:*:*:*:*:*:*:* | 15 | Running on | SUSE |
| cpe:2.3:a:opensuse:munge:*:*:*:*:*:*:*:* | before 0.5.13-6.1 | Vulnerable | openSUSE |
| cpe:2.3:a:opensuse:factory:-:*:*:*:*:*:*:* | not specified by NVD | Running on | openSUSE |
- cpe:2.3:a:opensuse:munge:*:*:*:*:*:*:*:* Versions before 0.5.13-4.3.1 Vulnerable ·openSUSE
- cpe:2.3:o:suse:suse_linux_enterprise_server:15:*:*:*:*:*:*:* Versions 15 Running on ·SUSE
- cpe:2.3:a:opensuse:munge:*:*:*:*:*:*:*:* Versions before 0.5.13-6.1 Vulnerable ·openSUSE
- cpe:2.3:a:opensuse:factory:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·openSUSE
Remediation
- Fix · CNA SUSE Linux Enterprise Server 15 (SUSE) Fixed in 0.5.13-4.3.1
- Fix · CNA Factory (openSUSE) Fixed in 0.5.13-6.1
Timeline
- 2026-10-02 Threatist record created from CVE-2019-3691
- 2026-10-03 Alias added: GHSA-q63p-x3h7-v3p5
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-3691 · CVE Program
- CVE-2019-3691 · NVD
- FIRST EPSS
- GHSA-q63p-x3h7-v3p5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences