Local privilege escalation from user wwwrun to root in the packaging of mailman
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A symlink following vulnerability in the packaging of mailman in SUSE Linux Enterprise Server 11, SUSE Linux Enterprise Server 12; openSUSE Leap 15.1 allowed local attackers to escalate their privileges from user wwwrun to root. Additionally arbitrary files could be changed to group mailman. This issue affects: SUSE Linux Enterprise Server 11 mailman versions prior to 2.1.15-9.6.15.1. SUSE Linux Enterprise Server 12 mailman versions prior to 2.1.17-3.11.1. openSUSE Leap 15.1 mailman version 2.1.29-lp151.2.14 and prior versions.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | SUSE Linux Enterprise Server 11 | mailman to before 2.1.15-9.6.15.1 | 2.1.15-9.6.15.1 | Patch available | CNA |
| SUSE | SUSE Linux Enterprise Server 12 | mailman to before 2.1.17-3.11.1 | 2.1.17-3.11.1 | Patch available | CNA |
| openSUSE | Leap 15.1 | mailman – 2.1.29-lp151.2.14 | — | No fix listed | CNA |
- SUSE Linux Enterprise Server 11 VendorSUSE Affected mailman to before 2.1.15-9.6.15.1 Fixed in 2.1.15-9.6.15.1 Patch available CNA
- SUSE Linux Enterprise Server 12 VendorSUSE Affected mailman to before 2.1.17-3.11.1 Fixed in 2.1.17-3.11.1 Patch available CNA
- Leap 15.1 VendoropenSUSE Affected mailman – 2.1.29-lp151.2.14 Fixed in — No fix listed CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:suse:mailman:*:*:*:*:*:*:*:* | before 2.1.15-9.6.15.1 | Vulnerable | SUSE |
| cpe:2.3:o:suse:linux_enterprise_server:11:-:*:*:*:*:*:* | 11 | Running on | SUSE |
| cpe:2.3:a:suse:mailman:*:*:*:*:*:*:*:* | before 2.1.17-3.11.1 | Vulnerable | SUSE |
| cpe:2.3:o:suse:linux_enterprise_server:12:-:*:*:*:*:*:* | 12 | Running on | SUSE |
| cpe:2.3:a:suse:mailman:*:*:*:*:*:*:*:* | up to 2.1.29-lp151.2.14 | Vulnerable | SUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Running on | openSUSE |
| cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* | 15.0 sp1 | Vulnerable | openSUSE |
- cpe:2.3:a:suse:mailman:*:*:*:*:*:*:*:* Versions before 2.1.15-9.6.15.1 Vulnerable ·SUSE
- cpe:2.3:o:suse:linux_enterprise_server:11:-:*:*:*:*:*:* Versions 11 Running on ·SUSE
- cpe:2.3:a:suse:mailman:*:*:*:*:*:*:*:* Versions before 2.1.17-3.11.1 Vulnerable ·SUSE
- cpe:2.3:o:suse:linux_enterprise_server:12:-:*:*:*:*:*:* Versions 12 Running on ·SUSE
- cpe:2.3:a:suse:mailman:*:*:*:*:*:*:*:* Versions up to 2.1.29-lp151.2.14 Vulnerable ·SUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Running on ·openSUSE
- cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* Versions 15.0 sp1 Vulnerable ·openSUSE
Remediation
- Fix · CNA SUSE Linux Enterprise Server 11 (SUSE) Fixed in 2.1.15-9.6.15.1
- Fix · CNA SUSE Linux Enterprise Server 12 (SUSE) Fixed in 2.1.17-3.11.1
Timeline
- 2026-10-02 Threatist record created from CVE-2019-3693
- 2026-10-03 Alias added: GHSA-mjp9-97x3-23vj
References
Sources
- CVE-2019-3693 · CVE Program
- CVE-2019-3693 · NVD
- FIRST EPSS
- GHSA-mjp9-97x3-23vj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences