Dell SupportAssist Client versions prior to 3.2.0.90 contain a remote code execution…
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Dell SupportAssist Client versions prior to 3.2.0.90 contain a remote code execution vulnerability. An unauthenticated attacker, sharing the network access layer with the vulnerable system, can compromise the vulnerable system by tricking a victim user into downloading and executing arbitrary executables via SupportAssist client from attacker hosted sites.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA SupportAssist Client (Dell) Fixed in 3.2.0.90
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Dell SupportAssist Client 3.2.0.90
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2019-02737 Cross-site request forgery in Dell SupportAssist ClientPriority LOW 39
Timeline
- 2026-10-02 Threatist record created from CVE-2019-3719
- 2026-10-03 Alias added: GHSA-6hgm-wcrx-jjw5
References
More Dell Supportassist vulnerabilities
- TI-2019-02737 Cross-site request forgery in Dell SupportAssist Client CVSS 3.1HIGH 8.8
Sources
- CVE-2019-3719 · CVE Program
- CVE-2019-3719 · NVD
- FIRST EPSS
- GHSA-6hgm-wcrx-jjw5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences