Out-of-bounds read in mqtt-packet
Priority LOW 36CWE-126Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-126 and the CVSS impact.
Summary
A specifically malformed MQTT Subscribe packet crashes MQTT Brokers using the mqtt-packet module versions < 3.5.1, 4.0.0 - 4.1.3, 5.0.0 - 5.6.1, 6.0.0 - 6.1.2 for decoding.
Why it matters now
EPSS 0.01777 78th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed mqtt-packet (npm): 3.5.1, 4.1.3, 5.6.1 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | mqtt-packet | Vulnerable versions: < 3.5.1, 4.0.0 - 4.1.3, 5.0.0 - 5.6.1, 6.0.0 - 6.1.2 | — | No fix listed | CNA |
| — | mqtt-packet (npm) | before 3.5.1 | 3.5.1 | Patch available | GHSA-wv67-9jq7-8r69 |
| — | mqtt-packet (npm) | 4.0.0 to before 4.1.3 | 4.1.3 | Patch available | GHSA-wv67-9jq7-8r69 |
| — | mqtt-packet (npm) | 5.0.0 to before 5.6.1 | 5.6.1 | Patch available | GHSA-wv67-9jq7-8r69 |
| — | mqtt-packet (npm) | 6.0.0 to before 6.1.2 | 6.1.2 | Patch available | GHSA-wv67-9jq7-8r69 |
- mqtt-packet Vendor— Affected Vulnerable versions: < 3.5.1, 4.0.0 - 4.1.3, 5.0.0 - 5.6.1, 6.0.0 - 6.1.2 Fixed in — No fix listed CNA
- mqtt-packet (npm) Vendor— Affected before 3.5.1 Fixed in 3.5.1 Patch available GHSA-wv67-9jq7-8r69
- mqtt-packet (npm) Vendor— Affected 4.0.0 to before 4.1.3 Fixed in 4.1.3 Patch available GHSA-wv67-9jq7-8r69
- mqtt-packet (npm) Vendor— Affected 5.0.0 to before 5.6.1 Fixed in 5.6.1 Patch available GHSA-wv67-9jq7-8r69
- mqtt-packet (npm) Vendor— Affected 6.0.0 to before 6.1.2 Fixed in 6.1.2 Patch available GHSA-wv67-9jq7-8r69
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mqtt-packet_project:mqtt-packet:*:*:*:*:*:node.js:*:* | before 3.5.1; 4.0.0 – 4.1.3; 5.0.0 – 5.6.1; 6.0.0 – 6.1.2 | Vulnerable | Mqtt-packet Project |
- cpe:2.3:a:mqtt-packet_project:mqtt-packet:*:*:*:*:*:node.js:*:* Versions before 3.5.1; 4.0.0 – 4.1.3; 5.0.0 – 5.6.1; 6.0.0 – 6.1.2 Vulnerable ·Mqtt-packet Project
Remediation
- Fix · GHSA-wv67-9jq7-8r69 mqtt-packet (npm) Fixed in 3.5.1 Advisory →
- Fix · GHSA-wv67-9jq7-8r69 mqtt-packet (npm) Fixed in 4.1.3 Advisory →
- Fix · GHSA-wv67-9jq7-8r69 mqtt-packet (npm) Fixed in 5.6.1 Advisory →
- Fix · GHSA-wv67-9jq7-8r69 mqtt-packet (npm) Fixed in 6.1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-5432
- 2026-10-03 Alias added: GHSA-wv67-9jq7-8r69
References
More Mqtt-packet Project Mqtt-packet vulnerabilities
- TI-2016-08565 Uncontrolled resource consumption in HackerOne mqtt-packet node module CVSS 3.0HIGH 7.5
Sources
- CVE-2019-5432 · CVE Program
- CVE-2019-5432 · NVD
- FIRST EPSS
- GHSA-wv67-9jq7-8r69 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences