An Integer underflow in VLC Media Player versions < 3.0.7 leads to an out-of-band read.
Priority LOW 36CWE-191Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
An Integer underflow in VLC Media Player versions < 3.0.7 leads to an out-of-band read.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02825 86th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | VLC | Fixed in 3.0.7 | — | No fix listed | CNA |
- VLC Vendor— Affected Fixed in 3.0.7 Fixed in — No fix listed CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:videolan:vlc_media_player:*:*:*:*:*:*:*:* | before 3.0.7 | Vulnerable | VideoLAN |
| cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* | 15.0 sp1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:backports:sle-15:*:*:*:*:*:*:* | sle-15 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:* | 15.0 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
- cpe:2.3:a:videolan:vlc_media_player:*:*:*:*:*:*:*:* Versions before 3.0.7 Vulnerable ·VideoLAN
- cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* Versions 15.0 sp1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:backports:sle-15:*:*:*:*:*:*:* Versions sle-15 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:* Versions 15.0 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2019-5459
- 2026-10-03 Alias added: GHSA-pvmq-wghp-3g56
- 2026-10-08 CISA SSVC decision points changed
References
Sources
- CVE-2019-5459 · CVE Program
- CVE-2019-5459 · NVD
- FIRST EPSS
- GHSA-pvmq-wghp-3g56 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences