An unintended require vulnerability in <v0.5.5 larvitbase-api may allow an attacker to…
Priority LOW 35CWE-98Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-98.
Summary
An unintended require vulnerability in <v0.5.5 larvitbase-api may allow an attacker to load arbitrary non-production code (JavaScript file).
Why it matters now
EPSS 0.01289 70th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed larvitbase-api (npm): 0.5.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | larvitbase-api | 0.5.5 | — | No fix listed | CNA |
| — | larvitbase-api (npm) | before 0.5.5 | 0.5.5 | Patch available | GHSA-xf27-jqwv-gf3r |
- larvitbase-api Vendor— Affected 0.5.5 Fixed in — No fix listed CNA
- larvitbase-api (npm) Vendor— Affected before 0.5.5 Fixed in 0.5.5 Patch available GHSA-xf27-jqwv-gf3r
Remediation
- Fix · GHSA-xf27-jqwv-gf3r larvitbase-api (npm) Fixed in 0.5.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-5479
- 2026-10-03 Alias added: GHSA-xf27-jqwv-gf3r
References
Sources
- CVE-2019-5479 · CVE Program
- CVE-2019-5479 · NVD
- FIRST EPSS
- GHSA-xf27-jqwv-gf3r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences