Seneca < 3.9.0 contains a vulnerability that could lead to exposing environment variables to unauthorized users.
Priority LOW 26CWE-209Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-209.
Summary
Seneca < 3.9.0 contains a vulnerability that could lead to exposing environment variables to unauthorized users.
Why it matters now
EPSS 0.01181 67th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed seneca (npm): 3.9.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | seneca | Fixed versions >= 3.9.0 | — | No fix listed | CNA |
| — | seneca (npm) | before 3.9.0 | 3.9.0 | Patch available | GHSA-2xwv-3cc9-fp7c |
- seneca Vendor— Affected Fixed versions >= 3.9.0 Fixed in — No fix listed CNA
- seneca (npm) Vendor— Affected before 3.9.0 Fixed in 3.9.0 Patch available GHSA-2xwv-3cc9-fp7c
Remediation
- Fix · GHSA-2xwv-3cc9-fp7c seneca (npm) Fixed in 3.9.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-5483
- 2026-10-03 Alias added: GHSA-2xwv-3cc9-fp7c
References
Sources
- CVE-2019-5483 · CVE Program
- CVE-2019-5483 · NVD
- FIRST EPSS
- GHSA-2xwv-3cc9-fp7c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences