Read the docs
TI-2019-04060 Aliases CVE-2019-5729GHSA-f58w-649r-qjr9

Splunk-SDK-Python before 1.6.6 does not properly verify untrusted TLS server…

Priority LOW 36CWE-295Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Spoofing
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-295.

Summary

Splunk-SDK-Python before 1.6.6 does not properly verify untrusted TLS server certificates, which could result in man-in-the-middle attacks.

Why it matters now

EPSS 0.00702 53rd percentileScored 2026-11-07
Fix Fixed splunk-sdk (PyPI): 1.6.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—splunk-sdk (PyPI)before 1.6.61.6.6Patch availableGHSA-f58w-649r-qjr9
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • splunk-sdk (PyPI) Vendor— Affected before 1.6.6 Fixed in 1.6.6 Patch available GHSA-f58w-649r-qjr9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:splunk:software_development_kit:*:*:*:*:*:python:*:*before 1.6.6VulnerableSplunk
  • cpe:2.3:a:splunk:software_development_kit:*:*:*:*:*:python:*:* Versions before 1.6.6 Vulnerable ·Splunk

Remediation

  • Fix · GHSA-f58w-649r-qjr9 splunk-sdk (PyPI) Fixed in 1.6.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-5729
  2. 2026-10-03 Alias added: GHSA-f58w-649r-qjr9

References

Sources